summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/libnfs/libnfs-1.11.0.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-1.11.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/net-fs/libnfs/libnfs-1.11.0.ebuild b/net-fs/libnfs/libnfs-1.11.0.ebuild
deleted file mode 100644
index edc14e1cdcd6..000000000000
--- a/net-fs/libnfs/libnfs-1.11.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-AUTOTOOLS_AUTORECONF="1"
-
-inherit autotools-utils eutils
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
-fi
-
-DESCRIPTION="Client library for accessing NFS shares over a network"
-HOMEPAGE="https://github.com/sahlberg/libnfs"
-
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/8" # sub-slot matches SONAME major
-IUSE="examples static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}-${P}"
-
-src_install() {
- autotools-utils_src_install
- if use examples; then
- # --enable-examples configure switch just compiles them
- # better install sources instead
- exeinto /usr/share/doc/${PF}/examples/
- for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
- doexe examples/${program}.c
- done
- fi
-}