summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/samba/samba-4.9.17.ebuild')
-rw-r--r--net-fs/samba/samba-4.9.17.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/net-fs/samba/samba-4.9.17.ebuild b/net-fs/samba/samba-4.9.17.ebuild
index 3ad0587ccb32..9d8f3c2110ea 100644
--- a/net-fs/samba/samba-4.9.17.ebuild
+++ b/net-fs/samba/samba-4.9.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -46,26 +46,28 @@ CDEPEND="
dev-libs/libbsd[${MULTILIB_USEDEP}]
dev-libs/iniparser:0
dev-libs/popt[${MULTILIB_USEDEP}]
- dev-python/subunit[${PYTHON_USEDEP},${MULTILIB_USEDEP}]
>=dev-util/cmocka-1.1.1[${MULTILIB_USEDEP}]
net-libs/libnsl:=[${MULTILIB_USEDEP}]
sys-apps/attr[${MULTILIB_USEDEP}]
- >=sys-libs/ldb-1.4.8[ldap(+)?,python?,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
- <sys-libs/ldb-1.5.0[ldap(+)?,python?,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
+ >=sys-libs/ldb-1.4.8[ldap(+)?,python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+ <sys-libs/ldb-1.5.0[ldap(+)?,python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
sys-libs/libcap
sys-libs/ncurses:0=[${MULTILIB_USEDEP}]
sys-libs/readline:0=
- >=sys-libs/talloc-2.1.14[python?,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
- >=sys-libs/tdb-1.3.16[python?,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
- >=sys-libs/tevent-0.9.37[python?,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
+ >=sys-libs/talloc-2.1.14[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+ >=sys-libs/tdb-1.3.16[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+ >=sys-libs/tevent-0.9.37[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]
virtual/libiconv
pam? ( sys-libs/pam )
acl? ( virtual/acl )
- addns? (
- net-dns/bind-tools[gssapi]
- dev-python/dnspython:=[${PYTHON_USEDEP}]
- )
+ $(python_gen_cond_dep "
+ dev-python/subunit[\${PYTHON_MULTI_USEDEP},${MULTILIB_USEDEP}]
+ addns? (
+ net-dns/bind-tools[gssapi]
+ dev-python/dnspython:=[\${PYTHON_MULTI_USEDEP}]
+ )
+ ")
ceph? ( sys-cluster/ceph )
cluster? (
net-libs/rpcsvc-proto