summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/atftp')
-rw-r--r--net-ftp/atftp/Manifest2
-rw-r--r--net-ftp/atftp/atftp-0.7-r6.ebuild78
-rw-r--r--net-ftp/atftp/files/atftp-0.7-CFLAGS.patch32
-rw-r--r--net-ftp/atftp/files/atftp-0.7-blockno.patch136
-rw-r--r--net-ftp/atftp/files/atftp-0.7-glibc24.patch22
-rw-r--r--net-ftp/atftp/files/atftp-0.7-illreply.patch12
-rw-r--r--net-ftp/atftp/files/atftp-0.7-password.patch94
-rw-r--r--net-ftp/atftp/files/atftp-0.7-pcre.patch14
-rw-r--r--net-ftp/atftp/files/atftp-0.7-spaced_filename.patch96
-rw-r--r--net-ftp/atftp/files/atftp-0.7-tests.patch23
10 files changed, 0 insertions, 509 deletions
diff --git a/net-ftp/atftp/Manifest b/net-ftp/atftp/Manifest
index 37c22b689771..eccbf7737c89 100644
--- a/net-ftp/atftp/Manifest
+++ b/net-ftp/atftp/Manifest
@@ -1,3 +1 @@
DIST atftp-0.7.2.tar.gz 248038 BLAKE2B 3ca44624bf989009c2ebd0ae97927b0784e3c617a79a1bd00212a72a185302cf84f51c8bcda2012981d67cfed4d241b70f8719e78155207608f07a2227e6c437 SHA512 d602bb69451175a36e619abcff412ab1f6d0e7baf8c3f9a2b32081530fbc5816157404b80d42a8b6caa89cc83675b5cbeefcd57a5d98b8f5b43c6254b20ef28b
-DIST atftp-0.7.dfsg.tar.gz 187992 BLAKE2B 8196c333ea8042879196ca9f9c656b4d60a332ed1d64a5738870e1d4fd5f108716da6769bf52759626ad3efce11946b5d6285ac9fbe46cb63e6e2d051fc7aeb3 SHA512 40d231c0bc0478fedb3eff9b4c540c62dd9bd6c40d9738e2db1813797a5d48e201720d43a48970ce250f1bb5b15460bb9b3d631c06f96c1a74775ecfb6d13f82
-DIST atftp_0.7-11.diff.gz 26055 BLAKE2B c9be58836b5a7e3943dd28dd4661abab5e86b1941c9a2b58786eebe702ab515cf1bc08bf44c8ab4157584a437e861e24eb0c833c1fa1bc774f7f8a2134b6cd27 SHA512 28747f8f3ef2fc3b122361f682fe26ba93acf09b190f61efb3cfcbb6bdeef78cfe1348aeaf1699003a7e02586579be670d85b65baad1b1165a4bec9a9279adb5
diff --git a/net-ftp/atftp/atftp-0.7-r6.ebuild b/net-ftp/atftp/atftp-0.7-r6.ebuild
deleted file mode 100644
index 64badd5fa1e9..000000000000
--- a/net-ftp/atftp/atftp-0.7-r6.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools flag-o-matic systemd
-
-DEBIAN_PV="11"
-DEBIAN_A="${PN}_${PV}-${DEBIAN_PV}.diff"
-
-DESCRIPTION="Advanced TFTP implementation client/server"
-HOMEPAGE="https://sourceforge.net/projects/atftp/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.dfsg.tar.gz
- mirror://debian/pool/main/a/${PN}/${DEBIAN_A}.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 ~s390 sparc x86"
-IUSE="selinux tcpd readline pcre"
-
-DEPEND="tcpd? ( sys-apps/tcp-wrappers )
- readline? ( sys-libs/readline:0= )
- pcre? ( dev-libs/libpcre )"
-RDEPEND="${DEPEND}
- !net-ftp/netkit-tftp
- !net-ftp/tftp-hpa
- !net-ftp/uftpd
- selinux? ( sec-policy/selinux-tftp )"
-
-PATCHES=(
- "${WORKDIR}/${DEBIAN_A}"
- "${FILESDIR}/${P}-pcre.patch"
- "${FILESDIR}/${P}-password.patch"
- "${FILESDIR}/${P}-tests.patch"
- "${FILESDIR}/${P}-glibc24.patch"
- "${FILESDIR}/${P}-blockno.patch"
- "${FILESDIR}/${P}-spaced_filename.patch"
- "${FILESDIR}/${P}-illreply.patch"
- "${FILESDIR}/${P}-CFLAGS.patch"
-)
-
-src_unpack() {
- default
- mv atftp-0.7.dfsg atftp-0.7 || die
-}
-
-src_prepare() {
- append-cppflags -D_REENTRANT -DRATE_CONTROL
- # fix #561720 by restoring pre-GCC5 inline semantics
- append-cflags -std=gnu89
-
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable tcpd libwrap) \
- $(use_enable readline libreadline) \
- $(use_enable pcre libpcre) \
- --enable-mtftp
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/atftp.init atftp
- newconfd "${FILESDIR}"/atftp.confd atftp
-
- systemd_dounit "${FILESDIR}"/atftp.service
- systemd_install_serviced "${FILESDIR}"/atftp.service.conf
-
- dodoc README* BUGS FAQ Changelog INSTALL TODO
- dodoc "${S}"/docs/*
-
- docinto test
- cd "${S}"/test || die
- dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
-}
diff --git a/net-ftp/atftp/files/atftp-0.7-CFLAGS.patch b/net-ftp/atftp/files/atftp-0.7-CFLAGS.patch
deleted file mode 100644
index 566c1791c591..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-CFLAGS.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- atftp-0.7/configure.ac
-+++ atftp-0.7/configure.ac
-@@ -66,29 +66,6 @@
- dnl Check for AIX
- AC_AIX
-
--CFLAGS="-g -Wall -D_REENTRANT"
--
--if test x$debug = xtrue; then
-- CFLAGS="$CFLAGS -O0 -DDEBUG"
--else
-- if test -n "$auto_cflags"; then
-- if test -n "$GCC"; then
-- CFLAGS="$CFLAGS -g -O2 -Wall -Wno-implicit"
-- else
-- case "$host_os" in
-- *hpux*) CFLAGS="$CFLAGS +O3"
-- ;;
-- *ultrix* | *osf*) CFLAGS="$CFLAGS -O -Olimit 2000"
-- ;;
-- *) CFLAGS="$CFLAGS -O2"
-- ;;
-- esac
-- fi
-- else
-- CFLAGS="$CFLAGS -O2"
-- fi
--fi
--
- AC_PROG_MAKE_SET
- AC_PROG_INSTALL
-
diff --git a/net-ftp/atftp/files/atftp-0.7-blockno.patch b/net-ftp/atftp/files/atftp-0.7-blockno.patch
deleted file mode 100644
index 6a3184f98bec..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-blockno.patch
+++ /dev/null
@@ -1,136 +0,0 @@
---- atftp-0.7/tftp_file.c~ 2010-05-27 13:05:12.000000000 -0500
-+++ atftp-0.7/tftp_file.c 2010-05-27 12:50:05.000000000 -0500
-@@ -133,19 +133,21 @@
- int mcast_sockfd = 0;
- struct sockaddr_in sa_mcast;
- struct ip_mreq mreq;
- struct hostent *host;
- int master_client = 0;
- unsigned int file_bitmap[NB_BLOCK];
- int prev_bitmap_hole = -1; /* the previous hole found in the bitmap */
- char string[MAXLEN];
-+ int rx_block_number;
-
- int prev_block_number = 0; /* needed to support netascii convertion */
- int temp = 0;
-+ size_t ignore;
-
- data->file_size = 0;
- tftp_cancel = 0;
- from.sin_addr.s_addr = 0;
-
- memset(&sa_mcast, 0, sizeof(struct sockaddr_in));
- memset(&file_bitmap, 0, sizeof(file_bitmap));
-
-@@ -300,17 +302,17 @@
- {
- connect(sockfd, (struct sockaddr *)&sa, sizeof(sa));
- connected = 1;
- }
- state = S_OACK_RECEIVED;
- break;
- case GET_ERROR:
- fprintf(stderr, "tftp: error received from server <");
-- fwrite(tftphdr->th_msg, 1, data_size - 4 - 1, stderr);
-+ ignore = fwrite(tftphdr->th_msg, 1, data_size - 4 - 1, stderr);
- fprintf(stderr, ">\n");
- state = S_ABORT;
- break;
- case GET_DATA:
- number_of_timeout = 0;
- /* if the socket if not connected, connect it */
- if (!connected)
- {
-@@ -513,21 +515,24 @@
- state = S_WAIT_PACKET;
- break;
- case S_DATA_RECEIVED:
- if ((multicast && master_client) || (!multicast))
- timeout_state = S_SEND_ACK;
- else
- timeout_state = S_WAIT_PACKET;
-
-- block_number = ntohs(tftphdr->th_block);
-+ rx_block_number = ntohs(tftphdr->th_block);
- if (data->trace)
- fprintf(stderr, "received DATA <block: %d, size: %d>\n",
- ntohs(tftphdr->th_block), data_size - 4);
-
-+ if ((uint16_t)rx_block_number == (uint16_t)(block_number+1))
-+ ++block_number;
-+
- if (tftp_file_write(fp, tftphdr->th_data, data->data_buffer_size - 4, block_number,
- data_size - 4, convert, &prev_block_number, &temp)
- != data_size - 4)
- {
-
- fprintf(stderr, "tftp: error writing to file %s\n",
- data->local_file);
- tftp_send_error(sockfd, &sa, ENOSPACE, data->data_buffer,
-@@ -613,19 +618,21 @@
- int connected; /* 1 when sockfd is connected */
- struct tftphdr *tftphdr = (struct tftphdr *)data->data_buffer;
- FILE *fp; /* the local file pointer */
- int number_of_timeout = 0;
- struct stat file_stat;
- int convert = 0; /* if true, do netascii convertion */
- char string[MAXLEN];
-
-+ int ack_block_number;
- int prev_block_number = 0; /* needed to support netascii convertion */
- int prev_file_pos = 0;
- int temp = 0;
-+ size_t ignore;
-
- data->file_size = 0;
- tftp_cancel = 0;
- from.sin_addr.s_addr = 0;
-
- /* make sure the socket is not connected */
- sa.sin_family = AF_UNSPEC;
- connect(sockfd, (struct sockaddr *)&sa, sizeof(sa));
-@@ -759,20 +766,23 @@
- case GET_ACK:
- number_of_timeout = 0;
- /* if the socket if not connected, connect it */
- if (!connected)
- {
- //connect(sockfd, (struct sockaddr *)&sa, sizeof(sa));
- connected = 1;
- }
-- block_number = ntohs(tftphdr->th_block);
-+ ack_block_number = ntohs(tftphdr->th_block);
-+ if ((uint16_t)(block_number+1) == ack_block_number)
-+ ++block_number;
- if (data->trace)
- fprintf(stderr, "received ACK <block: %d>\n",
-- block_number);
-+ ack_block_number);
-+
- if ((last_block != -1) && (block_number > last_block))
- {
- state = S_END;
- break;
- }
- state = S_SEND_DATA;
- break;
- case GET_OACK:
-@@ -782,17 +792,17 @@
- {
- //connect(sockfd, (struct sockaddr *)&sa, sizeof(sa));
- connected = 1;
- }
- state = S_OACK_RECEIVED;
- break;
- case GET_ERROR:
- fprintf(stderr, "tftp: error received from server <");
-- fwrite(tftphdr->th_msg, 1, data_size - 4 - 1, stderr);
-+ ignore = fwrite(tftphdr->th_msg, 1, data_size - 4 - 1, stderr);
- fprintf(stderr, ">\n");
- state = S_ABORT;
- break;
- case GET_DISCARD:
- /* consider discarded packet as timeout to make sure when don't lock up
- if routing is broken */
- number_of_timeout++;
- fprintf(stderr, "tftp: packet discard <%s:%d>.\n",
diff --git a/net-ftp/atftp/files/atftp-0.7-glibc24.patch b/net-ftp/atftp/files/atftp-0.7-glibc24.patch
deleted file mode 100644
index 195aec69b021..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-glibc24.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- atftp-0.7/stats.c.org
-+++ atftp-0.7/stats.c
-@@ -18,6 +18,7 @@
-
- #include <limits.h>
- #include <string.h>
-+#include <unistd.h>
- #include "tftp_def.h"
- #include "stats.h"
- #include "logger.h"
-@@ -157,8 +158,9 @@
-
- logger(LOG_INFO, " Load measurements:");
-+ long sc_clk_tck = sysconf(_SC_CLK_TCK);
- logger(LOG_INFO, " User: %8.3fs Sys:%8.3fs",
-- (double)(s_stats.tms.tms_utime) / CLK_TCK,
-- (double)(s_stats.tms.tms_stime) / CLK_TCK);
-+ (double)(s_stats.tms.tms_utime) / sc_clk_tck,
-+ (double)(s_stats.tms.tms_stime) / sc_clk_tck);
- logger(LOG_INFO, " Total:%8.3fs CPU:%8.3f%%",
- (double)(tmp.tv_sec + tmp.tv_usec * 1e-6),
- (double)(s_stats.tms.tms_utime + s_stats.tms.tms_stime) /
diff --git a/net-ftp/atftp/files/atftp-0.7-illreply.patch b/net-ftp/atftp/files/atftp-0.7-illreply.patch
deleted file mode 100644
index 0f1cacd9b955..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-illreply.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-*** atftp-0.7/tftp_def.old.c 2009-02-28 17:56:12.000000000 +0100
---- atftp-0.7/tftp_def.c 2009-02-28 17:57:02.000000000 +0100
-***************
-*** 141,146 ****
---- 141,147 ----
- */
- inline char *Strncpy(char *to, const char *from, size_t size)
- {
-+ if (size <= 0) { *to = '\000'; return to; }
- to[size-1] = '\000';
- return strncpy(to, from, size - 1);
- }
diff --git a/net-ftp/atftp/files/atftp-0.7-password.patch b/net-ftp/atftp/files/atftp-0.7-password.patch
deleted file mode 100644
index 26b59085dde5..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-password.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-diff -Naur atftp-0.7.orig/tftp.c atftp-0.7/tftp.c
---- atftp-0.7.orig/tftp.c 2004-03-15 18:55:56.000000000 -0500
-+++ atftp-0.7/tftp.c 2005-08-29 21:40:06.000000000 -0400
-@@ -525,6 +525,10 @@
- fprintf(stderr, " multicast: enabled\n");
- else
- fprintf(stderr, " multicast: disabled\n");
-+ if (data.tftp_options[OPT_PASSWORD].specified)
-+ fprintf(stderr, " password: enabled\n");
-+ else
-+ fprintf(stderr, " password: disabled\n");
- return ERR;
- }
- /* if disabling an option */
-@@ -971,6 +975,7 @@
- { "put", 0, NULL, 'p'},
- { "local-file", 1, NULL, 'l'},
- { "remote-file", 1, NULL, 'r'},
-+ { "password", 1, NULL, 'P'},
- { "tftp-timeout", 1, NULL, 'T'},
- { "mode", 1, NULL, 'M'},
- { "option", 1, NULL, 'O'},
-@@ -993,7 +998,7 @@
- };
-
- /* Support old argument until 0.8 */
-- while ((c = getopt_long(argc, argv, /*"gpl:r:Vh"*/ "gpl:r:Vht:b:sm",
-+ while ((c = getopt_long(argc, argv, /*"gpl:r:Vh"*/ "gpl:r:Vht:b:smP:",
- options, &option_index)) != EOF)
- {
- switch (c)
-@@ -1028,6 +1033,11 @@
- else
- action = PUT;
- break;
-+ case 'P':
-+ snprintf(string, sizeof(string), "option password %s", optarg);
-+ make_arg(string, &ac, &av);
-+ process_cmd(ac, av);
-+ break;
- case 'l':
- interactive = 0;
- Strncpy(local_file, optarg, MAXLEN);
-@@ -1169,6 +1179,7 @@
- " -p, --put : put file\n"
- " -l, --local-file <file> : local file name\n"
- " -r, --remote-file <file> : remote file name\n"
-+ " -P, --password <password>: specify password (Linksys ext.)\n"
- " --tftp-timeout <value> : delay before retransmission, client side\n"
- #if 0
- " t, --timeout <value> : delay before retransmission, "
-diff -Naur atftp-0.7.orig/tftp_def.c atftp-0.7/tftp_def.c
---- atftp-0.7.orig/tftp_def.c 2004-02-12 22:16:09.000000000 -0500
-+++ atftp-0.7/tftp_def.c 2005-08-29 21:36:57.000000000 -0400
-@@ -37,6 +37,7 @@
- { "timeout", "5", 0, 1 }, /* 2348, 2349, 2090. */
- { "blksize", "512", 0, 1 }, /* This is the default option */
- { "multicast", "", 0, 1 }, /* structure */
-+ { "password", "", 0, 1}, /* password */
- { "", "", 0, 0}
- };
-
-diff -Naur atftp-0.7.orig/tftp_def.h atftp-0.7/tftp_def.h
---- atftp-0.7.orig/tftp_def.h 2004-02-12 22:16:09.000000000 -0500
-+++ atftp-0.7/tftp_def.h 2005-08-29 20:16:27.000000000 -0400
-@@ -40,6 +40,7 @@
- #define OPT_TIMEOUT 3
- #define OPT_BLKSIZE 4
- #define OPT_MULTICAST 5
-+#define OPT_PASSWORD 6
- #define OPT_NUMBER 7
-
- #define OPT_SIZE 12
-diff -Naur atftp-0.7.orig/tftp_io.c atftp-0.7/tftp_io.c
---- atftp-0.7.orig/tftp_io.c 2004-02-18 20:30:00.000000000 -0500
-+++ atftp-0.7/tftp_io.c 2005-08-29 22:05:11.000000000 -0400
-@@ -70,10 +70,13 @@
- break;
- if (tftp_options[i].enabled && tftp_options[i].specified)
- {
-- Strncpy(data_buffer + buf_index, tftp_options[i].option,
-- data_buffer_size - buf_index);
-- buf_index += strlen(tftp_options[i].option);
-- buf_index++;
-+ if (i != OPT_PASSWORD)
-+ {
-+ Strncpy(data_buffer + buf_index, tftp_options[i].option,
-+ data_buffer_size - buf_index);
-+ buf_index += strlen(tftp_options[i].option);
-+ buf_index++;
-+ }
- Strncpy(data_buffer + buf_index, tftp_options[i].value,
- data_buffer_size - buf_index);
- buf_index += strlen(tftp_options[i].value);
diff --git a/net-ftp/atftp/files/atftp-0.7-pcre.patch b/net-ftp/atftp/files/atftp-0.7-pcre.patch
deleted file mode 100644
index 1f24b67471e2..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-pcre.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- atftp-0.7/tftpd_pcre.c~ 2005-10-17 23:14:52.000000000 +0200
-+++ atftp-0.7/tftpd_pcre.c 2005-10-17 23:14:52.000000000 +0200
-@@ -211,9 +211,9 @@
- chp++; /* point to value indicating substring */
- rc = pcre_get_substring(str, ovector, matches, *chp - 0x30, &tmpstr);
- /* found string */
-- if (rc > 0)
-+ if (rc > 0 && outchp - outstr + rc+1 < outsize)
- {
-- Strncpy(outchp, tmpstr, rc);
-+ Strncpy(outchp, tmpstr, rc+1);
- outchp += rc;
- pcre_free_substring(tmpstr);
- continue;
diff --git a/net-ftp/atftp/files/atftp-0.7-spaced_filename.patch b/net-ftp/atftp/files/atftp-0.7-spaced_filename.patch
deleted file mode 100644
index da96d9f6b820..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-spaced_filename.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- atftp-0.7/tftp.c~ 2010-06-03 08:51:14.000000000 -0500
-+++ atftp-0.7/tftp.c 2010-06-03 09:40:56.000000000 -0500
-@@ -18,16 +18,17 @@
- #include "config.h"
-
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
- #include <unistd.h>
- #include <getopt.h>
- #include <string.h>
-+#include <stdarg.h>
-
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <netdb.h>
-
- #include <signal.h>
-@@ -344,16 +345,41 @@
-
- /* If no names matched, then return NULL. */
- return NULL;
- }
- # endif
- #endif
-
- /*
-+ * set argc/argv from variadic string arguments
-+*/
-+void make_arg_vector(int *argc, char***argv, ...)
-+{
-+ char **p;
-+ char *s;
-+ va_list argp;
-+
-+ // how many args?
-+ *argc = 0;
-+ va_start(argp, argv);
-+ while ( (s=va_arg(argp, char*)) )
-+ ++*argc;
-+
-+ // allocate storage
-+ *argv = malloc(*argc * sizeof (char*));
-+
-+ // store args
-+ p = *argv;
-+ va_start(argp, argv);
-+ while ( (s=va_arg(argp, char*)) )
-+ *p++ = s;
-+}
-+
-+/*
- * Split a string into args.
- */
- void make_arg(char *string, int *argc, char ***argv)
- {
- static char *tmp = NULL;
- size_t argz_len;
-
- /* split the string to an argz vector */
-@@ -1142,30 +1168,26 @@
- argv[optind+1]);
- make_arg(string, &ac, &av);
- process_cmd(ac, av);
- }
-
- if (!interactive)
- {
- if (action == PUT)
-- snprintf(string, sizeof(string), "put %s %s", local_file,
-- remote_file);
-+ make_arg_vector(&ac,&av,"put",local_file,remote_file,NULL);
- else if (action == GET)
-- snprintf(string, sizeof(string), "get %s %s", remote_file,
-- local_file);
-+ make_arg_vector(&ac,&av,"get",remote_file,local_file,NULL);
- else if (action == MGET)
-- snprintf(string, sizeof(string), "mget %s %s", remote_file,
-- local_file);
-+ make_arg_vector(&ac,&av,"mget",remote_file,local_file,NULL);
- else
- {
- fprintf(stderr, "No action specified in batch mode!\n");
- exit(ERR);
- }
-- make_arg(string, &ac, &av);
- if (process_cmd(ac, av) == ERR)
- exit(ERR);
- }
- return OK;
- }
-
- void tftp_usage(void)
- {
diff --git a/net-ftp/atftp/files/atftp-0.7-tests.patch b/net-ftp/atftp/files/atftp-0.7-tests.patch
deleted file mode 100644
index 9e087950e659..000000000000
--- a/net-ftp/atftp/files/atftp-0.7-tests.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur atftp-0.7.orig/test/test.sh atftp-0.7/test/test.sh
---- atftp-0.7.orig/test/test.sh 2003-04-28 21:59:51.000000000 -0400
-+++ atftp-0.7/test/test.sh 2005-10-26 22:42:15.000000000 -0400
-@@ -151,7 +151,7 @@
- test_blocksize 1428
- test_blocksize 16000
- test_blocksize 64000
--test_blocksize 65465
-+test_blocksize 65464
-
- #
- # testing fot tsize
-@@ -162,9 +162,9 @@
- TSIZE=`grep "OACK <tsize:" out | sed -e "s/[^0-9]//g"`
- if [ "$TSIZE" != "2048" ]; then
- echo "ERROR (server report $TSIZE bytes but it should be 2048)"
-+ ERROR=1
- else
- echo "OK"
-- ERROR=1
- fi
-
- #