summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/files/filezilla-3.66.4-gcc14.patch27
-rw-r--r--net-ftp/filezilla/filezilla-3.66.4.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/net-ftp/filezilla/files/filezilla-3.66.4-gcc14.patch b/net-ftp/filezilla/files/filezilla-3.66.4-gcc14.patch
new file mode 100644
index 000000000000..0c66931d31aa
--- /dev/null
+++ b/net-ftp/filezilla/files/filezilla-3.66.4-gcc14.patch
@@ -0,0 +1,27 @@
+diff --git a/src/putty/unix/uxsftp.c b/src/putty/unix/uxsftp.c
+index f078d97..05ec2ff 100644
+--- a/src/putty/unix/uxsftp.c
++++ b/src/putty/unix/uxsftp.c
+@@ -211,7 +211,7 @@ int read_from_file(RFile *f, void *buffer, int length)
+ #if 1
+ if (f->state == ok && !f->remaining_) {
+ fznotify1(sftp_io_nextbuf, 0);
+- char const* s = priority_read();
++ char *s = priority_read();
+ if (s[1] == '-') {
+ f->state = error;
+ return -1;
+@@ -220,11 +220,11 @@ int read_from_file(RFile *f, void *buffer, int length)
+ f->state = eof;
+ }
+ else {
+- char const* p = s + 1;
++ char *p = s + 1;
+ f->buffer_ = f->memory_ + next_int(&p);
+ f->remaining_ = (int)next_int(&p);
+ }
+- sfree(s);
++ sfree((void *)s);
+ }
+ if (f->state == eof) {
+ return 0;
diff --git a/net-ftp/filezilla/filezilla-3.66.4.ebuild b/net-ftp/filezilla/filezilla-3.66.4.ebuild
index 3355a66cdf57..b13ff09bc0eb 100644
--- a/net-ftp/filezilla/filezilla-3.66.4.ebuild
+++ b/net-ftp/filezilla/filezilla-3.66.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -45,6 +45,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
"${FILESDIR}"/${PN}-3.52.2-slibtool.patch
"${FILESDIR}"/${PN}-3.60.1-desktop.patch
+ "${FILESDIR}"/${PN}-3.66.4-gcc14.patch
)
src_prepare() {