summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/linksys-tftp/linksys-tftp-1.2.1-r4.ebuild')
-rw-r--r--net-ftp/linksys-tftp/linksys-tftp-1.2.1-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r4.ebuild b/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r4.ebuild
new file mode 100644
index 000000000000..7a669f8ed51f
--- /dev/null
+++ b/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="TFTP client suitable for uploading to the Linksys WRT54G Wireless Router"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://www.redsand.net/solutions/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-r1-header.patch"
+ "${FILESDIR}/${P}-r1-Makefile.patch"
+ "${FILESDIR}/${P}-r1-fno-common.patch"
+ "${FILESDIR}/${P}-r1-clang.patch"
+ "${FILESDIR}/${P}-r4-c99-port.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin linksys-tftp
+ einstalldocs
+}