summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/choqok/choqok-1.7.0.ebuild')
-rw-r--r--net-im/choqok/choqok-1.7.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-im/choqok/choqok-1.7.0.ebuild b/net-im/choqok/choqok-1.7.0.ebuild
index b610393b434a..a6a4bf140c46 100644
--- a/net-im/choqok/choqok-1.7.0.ebuild
+++ b/net-im/choqok/choqok-1.7.0.ebuild
@@ -48,9 +48,9 @@ DEPEND="
>=kde-frameworks/sonnet-${KFMIN}:5
attica? ( >=kde-frameworks/attica-${KFMIN}:5 )
konqueror? (
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/kdewebkit-${KFMIN}:5
- >=dev-qt/qtwebkit-5.212.0_pre20180120:5
)
share? ( >=kde-frameworks/purpose-${KFMIN}:5 )
telepathy? ( net-libs/telepathy-qt[qt5(+)] )
@@ -59,6 +59,12 @@ RDEPEND="${DEPEND}"
DOCS=( AUTHORS README changelog )
+src_prepare() {
+ ecm_src_prepare
+ # TODO: quick fix for bug #708464
+ sed -e "/find_package.*Purpose)/s/ COMPONENTS //" -i CMakeLists.txt || die
+}
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package attica KF5Attica)