summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/Manifest3
-rw-r--r--net-im/dino/dino-0.1.0.ebuild87
-rw-r--r--net-im/dino/dino-0.4.2-r2.ebuild99
-rw-r--r--net-im/dino/dino-0.4.3-r1.ebuild103
-rw-r--r--net-im/dino/dino-0.4.3.ebuild99
-rw-r--r--net-im/dino/dino-9999.ebuild78
-rw-r--r--net-im/dino/files/README.gentoo23
-rw-r--r--net-im/dino/files/dino-0.4.3-c99.patch57
-rw-r--r--net-im/dino/metadata.xml9
9 files changed, 432 insertions, 126 deletions
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
index f126436b1b32..674adcabd18e 100644
--- a/net-im/dino/Manifest
+++ b/net-im/dino/Manifest
@@ -1 +1,2 @@
-DIST dino-0.1.0.tar.gz 441638 BLAKE2B 08f332d38af866eed1049fae7d0e207da5a3486fdaf07eb5327e7abf614ac4adc130fd8f2d9465d6cb248ecfe4b809e022a69c72df5879d98719d24635771b33 SHA512 b63bf87dbf7f728f038f22d0dba34770a06d7eb1be2ec249293ff876e16c151165add895ff3cb20a3216c3581d20e10634d454ee8b024b895012efb34f9d7de8
+DIST dino-0.4.2.tar.gz 882421 BLAKE2B 36c0487a19202506e4de69afd923991c912e82c974f61e787ff4af37a40133fdbdb02315e82f7e85ccb8b3cd7d734aed7f8508ca31c1ffec49674ef68f71793b SHA512 b5d5b9e2ab2ff24f53778303e5428ed0613537944cf5d9139aa7e13558ee40ffb1566c6e9267dd802938a6abf0f0d5fbe94ef17fb3e18a11d47cc0d040928d19
+DIST dino-0.4.3.tar.gz 883558 BLAKE2B 31ea5eafedcaabbc1ec99c72b5a0c1a6f80462ce3f8288b2d54d68106cfb9a31d3ac525660cd1ff7bf0faf2fbfdb2f47dd37672cc0f2b3283121fd364f670092 SHA512 c3e5e3ba05d7190206a8a3144002eac94f162525ab229edd420215eff3d5644293d0c8737266f0ed9f112313b2e6e83fb02fcc10d0f568fb5b2295238ebe78ea
diff --git a/net-im/dino/dino-0.1.0.ebuild b/net-im/dino/dino-0.1.0.ebuild
deleted file mode 100644
index 107f28ed4d27..000000000000
--- a/net-im/dino/dino-0.1.0.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CMAKE_MAKEFILE_GENERATOR="ninja"
-VALA_MIN_API_VERSION="0.34"
-inherit cmake-utils gnome2-utils vala xdg-utils
-
-DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
-HOMEPAGE="https://dino.im"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+gpg +http +omemo"
-
-MY_REPO_URI="https://github.com/dino/dino"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="${MY_REPO_URI}.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-RDEPEND="
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/icu
- dev-libs/libgee:0.8
- net-libs/glib-networking
- ~net-libs/libsignal-protocol-c-2.3.2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- gpg? ( app-crypt/gpgme:1 )
- http? ( net-libs/libsoup:2.4 )
- omemo? (
- dev-libs/libgcrypt:0
- media-gfx/qrencode
- )
-"
-DEPEND="
- $(vala_depend)
- ${RDEPEND}
- sys-devel/gettext
-"
-
-src_prepare() {
- cmake-utils_src_prepare
- vala_src_prepare
-}
-
-src_configure() {
- local disabled_plugins=(
- $(usex gpg "" "openpgp")
- $(usex omemo "" "omemo")
- $(usex http "" "http-files")
- )
- local mycmakeargs+=(
- "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
- "-DVALA_EXECUTABLE=${VALAC}"
- )
-
- if has test ${FEATURES}; then
- mycmakeargs+=("-DBUILD_TESTS=yes")
- fi
-
- cmake-utils_src_configure
-}
-
-src_test() {
- "${BUILD_DIR}"/xmpp-vala-test || die
-}
-
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
-}
diff --git a/net-im/dino/dino-0.4.2-r2.ebuild b/net-im/dino/dino-0.4.2-r2.ebuild
new file mode 100644
index 000000000000..de4977426bc8
--- /dev/null
+++ b/net-im/dino/dino-0.4.2-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake vala xdg readme.gentoo-r1
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gpg +http +omemo +notification-sound +rtp test"
+RESTRICT="!test? ( test )"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="amd64 ~arm64"
+ SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/icu:=
+ dev-libs/libgee:0.8=
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.2.0:1[vala]
+ media-libs/graphene
+ net-libs/glib-networking
+ net-libs/gnutls:=
+ >=net-libs/libnice-0.1.15
+ net-libs/libsignal-protocol-c
+ net-libs/libsrtp:2=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ gpg? ( app-crypt/gpgme:= )
+ http? ( net-libs/libsoup:2.4 )
+ notification-sound? ( media-libs/libcanberra:0[sound] )
+ omemo? (
+ dev-libs/libgcrypt:=
+ media-gfx/qrencode:=
+ )
+ rtp? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/webrtc-audio-processing:0
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ media-libs/gst-plugins-base
+ media-libs/gstreamer
+"
+BDEPEND="
+ sys-devel/gettext
+ $(vala_depend)
+"
+
+src_configure() {
+ vala_setup
+
+ local disabled_plugins=(
+ $(usex gpg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ $(usex rtp "" rtp)
+ )
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
+ local mycmakeargs=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ "-DVALA_EXECUTABLE=${VALAC}"
+ "-DSOUP_VERSION=2"
+ "-DBUILD_TESTS=$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/net-im/dino/dino-0.4.3-r1.ebuild b/net-im/dino/dino-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..0badcf1fd992
--- /dev/null
+++ b/net-im/dino/dino-0.4.3-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake vala xdg readme.gentoo-r1
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gpg +http +omemo +notification-sound +rtp test"
+RESTRICT="!test? ( test )"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm64"
+ SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/icu:=
+ dev-libs/libgee:0.8=
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.2.0:1[vala]
+ media-libs/graphene
+ net-libs/glib-networking
+ net-libs/gnutls:=
+ >=net-libs/libnice-0.1.15
+ net-libs/libsignal-protocol-c
+ net-libs/libsrtp:2=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ gpg? ( app-crypt/gpgme:= )
+ http? ( net-libs/libsoup:2.4 )
+ notification-sound? ( media-libs/libcanberra:0[sound] )
+ omemo? (
+ dev-libs/libgcrypt:=
+ media-gfx/qrencode:=
+ )
+ rtp? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/webrtc-audio-processing:0
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ media-libs/gst-plugins-base
+ media-libs/gstreamer
+"
+BDEPEND="
+ sys-devel/gettext
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-c99.patch
+)
+
+src_configure() {
+ vala_setup
+
+ local disabled_plugins=(
+ $(usex gpg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ $(usex rtp "" rtp)
+ )
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
+ local mycmakeargs=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ "-DVALA_EXECUTABLE=${VALAC}"
+ "-DSOUP_VERSION=2"
+ "-DBUILD_TESTS=$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/net-im/dino/dino-0.4.3.ebuild b/net-im/dino/dino-0.4.3.ebuild
new file mode 100644
index 000000000000..443a60ca974f
--- /dev/null
+++ b/net-im/dino/dino-0.4.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake vala xdg readme.gentoo-r1
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gpg +http +omemo +notification-sound +rtp test"
+RESTRICT="!test? ( test )"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm64"
+ SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/icu:=
+ dev-libs/libgee:0.8=
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.2.0:1[vala]
+ media-libs/graphene
+ net-libs/glib-networking
+ net-libs/gnutls:=
+ >=net-libs/libnice-0.1.15
+ net-libs/libsignal-protocol-c
+ net-libs/libsrtp:2=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ gpg? ( app-crypt/gpgme:= )
+ http? ( net-libs/libsoup:2.4 )
+ notification-sound? ( media-libs/libcanberra:0[sound] )
+ omemo? (
+ dev-libs/libgcrypt:=
+ media-gfx/qrencode:=
+ )
+ rtp? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/webrtc-audio-processing:0
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ media-libs/gst-plugins-base
+ media-libs/gstreamer
+"
+BDEPEND="
+ sys-devel/gettext
+ $(vala_depend)
+"
+
+src_configure() {
+ vala_setup
+
+ local disabled_plugins=(
+ $(usex gpg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ $(usex rtp "" rtp)
+ )
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
+ local mycmakeargs=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ "-DVALA_EXECUTABLE=${VALAC}"
+ "-DSOUP_VERSION=2"
+ "-DBUILD_TESTS=$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index 937678aeb91c..443a60ca974f 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -1,87 +1,99 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-CMAKE_MAKEFILE_GENERATOR="ninja"
-VALA_MIN_API_VERSION="0.34"
-inherit cmake-utils gnome2-utils vala xdg-utils
+inherit cmake vala xdg readme.gentoo-r1
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
HOMEPAGE="https://dino.im"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo"
+IUSE="+gpg +http +omemo +notification-sound +rtp test"
+RESTRICT="!test? ( test )"
MY_REPO_URI="https://github.com/dino/dino"
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="${MY_REPO_URI}.git"
inherit git-r3
else
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
fi
RDEPEND="
dev-db/sqlite:3
dev-libs/glib:2
- dev-libs/icu
- dev-libs/libgee:0.8
+ dev-libs/icu:=
+ dev-libs/libgee:0.8=
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.2.0:1[vala]
+ media-libs/graphene
net-libs/glib-networking
+ net-libs/gnutls:=
+ >=net-libs/libnice-0.1.15
net-libs/libsignal-protocol-c
+ net-libs/libsrtp:2=
x11-libs/cairo
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
x11-libs/pango
- gpg? ( app-crypt/gpgme:1 )
+ gpg? ( app-crypt/gpgme:= )
http? ( net-libs/libsoup:2.4 )
+ notification-sound? ( media-libs/libcanberra:0[sound] )
omemo? (
- dev-libs/libgcrypt:0
- media-gfx/qrencode
+ dev-libs/libgcrypt:=
+ media-gfx/qrencode:=
+ )
+ rtp? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/webrtc-audio-processing:0
)
"
DEPEND="
- $(vala_depend)
${RDEPEND}
+ media-libs/gst-plugins-base
+ media-libs/gstreamer
+"
+BDEPEND="
sys-devel/gettext
+ $(vala_depend)
"
-src_prepare() {
- cmake-utils_src_prepare
- vala_src_prepare
-}
-
src_configure() {
+ vala_setup
+
local disabled_plugins=(
$(usex gpg "" "openpgp")
$(usex omemo "" "omemo")
$(usex http "" "http-files")
+ $(usex rtp "" rtp)
+ )
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
)
- local mycmakeargs+=(
+ local mycmakeargs=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
"-DVALA_EXECUTABLE=${VALAC}"
+ "-DSOUP_VERSION=2"
+ "-DBUILD_TESTS=$(usex test)"
)
- if has test ${FEATURES}; then
- mycmakeargs+=("-DBUILD_TESTS=yes")
- fi
-
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
"${BUILD_DIR}"/xmpp-vala-test || die
}
-update_caches() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
}
pkg_postinst() {
- update_caches
-}
-
-pkg_postrm() {
- update_caches
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
}
diff --git a/net-im/dino/files/README.gentoo b/net-im/dino/files/README.gentoo
new file mode 100644
index 000000000000..b51e4391562e
--- /dev/null
+++ b/net-im/dino/files/README.gentoo
@@ -0,0 +1,23 @@
+To enable video calls, install the following packages.
+
+Transport level security:
+- gst-plugins-srtp
+- gst-plugins-dtls
+
+Peer to peer connection reliability:
+- gst-plugins-libnice
+
+Video output into a window:
+- gst-plugins-gtk
+
+At least one codec is needed in common with the other end of the call, as they
+are negotiated when the call begins.
+
+Video codecs:
+- gst-plugins-x264
+- gst-plugins-vpx
+
+Audio codecs:
+- gst-plugins-good
+- gst-plugins-speex
+- gst-plugins-opus
diff --git a/net-im/dino/files/dino-0.4.3-c99.patch b/net-im/dino/files/dino-0.4.3-c99.patch
new file mode 100644
index 000000000000..d21ff5e4adec
--- /dev/null
+++ b/net-im/dino/files/dino-0.4.3-c99.patch
@@ -0,0 +1,57 @@
+https://bugs.gentoo.org/926073
+https://github.com/dino/dino/commit/0c45387bf903e5b0d02502d27642dd2a78aa6539
+
+From 0c45387bf903e5b0d02502d27642dd2a78aa6539 Mon Sep 17 00:00:00 2001
+From: fiaxh <git@lightrise.org>
+Date: Sat, 7 Oct 2023 13:56:38 +0200
+Subject: [PATCH] Fix implicit-function-declaration compiler warnings
+
+--- a/xmpp-vala/src/module/xep/0384_omemo/omemo_encryptor.vala
++++ b/xmpp-vala/src/module/xep/0384_omemo/omemo_encryptor.vala
+@@ -72,27 +72,27 @@ namespace Xmpp.Xep.Omemo {
+ }
+
+ public class EncryptionResult {
+- public int lost { get; internal set; }
+- public int success { get; internal set; }
+- public int unknown { get; internal set; }
+- public int failure { get; internal set; }
++ public int lost { get; set; }
++ public int success { get; set; }
++ public int unknown { get; set; }
++ public int failure { get; set; }
+ }
+
+ public class EncryptState {
+- public bool encrypted { get; internal set; }
+- public int other_devices { get; internal set; }
+- public int other_success { get; internal set; }
+- public int other_lost { get; internal set; }
+- public int other_unknown { get; internal set; }
+- public int other_failure { get; internal set; }
+- public int other_waiting_lists { get; internal set; }
+-
+- public int own_devices { get; internal set; }
+- public int own_success { get; internal set; }
+- public int own_lost { get; internal set; }
+- public int own_unknown { get; internal set; }
+- public int own_failure { get; internal set; }
+- public bool own_list { get; internal set; }
++ public bool encrypted { get; set; }
++ public int other_devices { get; set; }
++ public int other_success { get; set; }
++ public int other_lost { get; set; }
++ public int other_unknown { get; set; }
++ public int other_failure { get; set; }
++ public int other_waiting_lists { get; set; }
++
++ public int own_devices { get; set; }
++ public int own_success { get; set; }
++ public int own_lost { get; set; }
++ public int own_unknown { get; set; }
++ public int own_failure { get; set; }
++ public bool own_list { get; set; }
+
+ public void add_result(EncryptionResult enc_res, bool own) {
+ if (own) {
+
diff --git a/net-im/dino/metadata.xml b/net-im/dino/metadata.xml
index 05d64fd0a3f9..8798c1dab8d4 100644
--- a/net-im/dino/metadata.xml
+++ b/net-im/dino/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>andrey_utkin@gentoo.org</email>
- <name>Andrey Utkin</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<bugs-to>https://github.com/dino/dino/issues</bugs-to>
<remote-id type="github">dino/dino</remote-id>
@@ -13,5 +10,7 @@
<flag name="gpg">Enable OpenPGP encryption plugin</flag>
<flag name="http">Enable HTTP file upload plugin</flag>
<flag name="omemo">Enable OMEMO encryption plugin</flag>
+ <flag name="notification-sound">notification sounds plugin</flag>
+ <flag name="rtp">Enable Audio/Video calls over XMPP using RTP</flag>
</use>
</pkgmetadata>