summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/psi/psi-9999.ebuild')
-rw-r--r--net-im/psi/psi-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-im/psi/psi-9999.ebuild b/net-im/psi/psi-9999.ebuild
index 56868b48352b..20f9be17efad 100644
--- a/net-im/psi/psi-9999.ebuild
+++ b/net-im/psi/psi-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="be bg ca cs de en eo es et fa fi fr he hu it ja kk mk nl pl pt pt_BR ru sk sl sr@latin sv sw uk ur_PK vi zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit l10n git-r3 qmake-utils
+inherit l10n git-r3 qmake-utils xdg-utils
DESCRIPTION="Qt XMPP client"
HOMEPAGE="http://psi-im.org/"
@@ -187,3 +187,13 @@ src_install() {
}
l10n_for_each_locale_do install_locale
}
+
+pkg_postinst(){
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}