summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/ricochet/ricochet-9999.ebuild')
-rw-r--r--net-im/ricochet/ricochet-9999.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/net-im/ricochet/ricochet-9999.ebuild b/net-im/ricochet/ricochet-9999.ebuild
deleted file mode 100644
index b770332effdf..000000000000
--- a/net-im/ricochet/ricochet-9999.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnome2-utils qmake-utils
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ricochet-im/ricochet"
-else
- SRC_URI="https://github.com/ricochet-im/ricochet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Privacy-focused instant messaging through Tor hidden services"
-HOMEPAGE="https://ricochet.im"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="debug hardened"
-
-RDEPEND="
- dev-libs/openssl:0=
- dev-libs/protobuf:0=
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtquickcontrols:5
- dev-qt/qtwidgets:5
- net-vpn/tor"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig"
-
-src_prepare() {
- eapply_user
-
- # workaround bug https://github.com/ricochet-im/ricochet/issues/582
- cp contrib/usr.bin.ricochet-apparmor contrib/usr.bin.ricochet
-}
-
-src_configure() {
- local qmakeargs=( 'DEFINES+=RICOCHET_NO_PORTABLE' )
- qmakeargs+=( 'DEFINES+=APPARMOR' )
- qmakeargs+=( $(usex debug 'CONFIG+=debug' 'CONFIG+=release') )
- qmakeargs+=( $(usex hardened 'CONFIG+=hardened' 'CONFIG+=no-hardened') )
-
- eqmake5 "${qmakeargs[@]}"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}