summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild')
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
new file mode 100644
index 000000000000..c5dec761f9fd
--- /dev/null
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ORIG_PN="${PN%-amm}"
+
+DESCRIPTION="Send XMPP (Jabber) messages via command line"
+HOMEPAGE="https://github.com/flowdalic/sendxmpp"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/Flowdalic/${ORIG_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64"
+ S="${WORKDIR}/${ORIG_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+
+SLOT="0"
+
+RDEPEND="
+ dev-lang/ammonite-repl-bin[scala2-13]
+ !net-im/sendxmpp
+"
+
+src_prepare() {
+ default
+ # Ensure that the script is using the right Scala version.
+ sed -i '1 s;^.*$;#!/usr/bin/env amm-2.13;' sendxmpp.sc || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ newbin sendxmpp.sc sendxmpp
+}