summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telegram-desktop/files')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch100
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch122
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch31
3 files changed, 253 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch
new file mode 100644
index 000000000000..dff2455d4e3d
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch
@@ -0,0 +1,100 @@
+Allow controlling the use of jemalloc
+
+Jemalloc is often controlled through USE=jemalloc in Gentoo. Removing or
+replacing it is trivial, and I'm not aware of any particular advantages that
+come with using this allocator, especially for an IM client. Benchmarks
+regarding this allocator provide a huge variety of results depending on the
+workload and system, so it's hard to establish when this allocator provides any
+tangible advantage.
+
+Considering things like Hardened Gentoo, the user might prefer to use a more
+exploit-resistant allocator, like GrapheneOS/hardened_malloc, and I've heard
+Musl is hardening their allocator as well.
+
+I trust the user can better judge if they need this in their particular setup.
+
+If a telegram dev is reading this, feel free to drop me a message (metadata.xml
+contains the maintainer's address), if you believe it should be forced due to
+usability concerns, or if you can provide me with some context I might be
+missing. Jemalloc is currently enabled by default.
+
+--- tdesktop-2.8.9-full.orig/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ tdesktop-2.8.9-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -48,7 +48,10 @@
+ #include <gio/gio.h>
+ #include <glibmm.h>
+ #include <giomm.h>
++
++#ifndef DESKTOP_APP_DISABLE_JEMALLOC
+ #include <jemalloc/jemalloc.h>
++#endif // !DESKTOP_APP_DISABLE_JEMALLOC
+
+ #include <sys/stat.h>
+ #include <sys/types.h>
+@@ -727,8 +730,10 @@
+ namespace Platform {
+
+ void start() {
++#ifndef DESKTOP_APP_DISABLE_JEMALLOC
+ auto backgroundThread = true;
+ mallctl("background_thread", nullptr, nullptr, &backgroundThread, sizeof(bool));
++#endif // !DESKTOP_APP_DISABLE_JEMALLOC
+
+ LOG(("Launcher filename: %1").arg(QGuiApplication::desktopFileName()));
+
+--- tdesktop-2.8.9-full.orig/cmake/external/CMakeLists.txt
++++ tdesktop-2.8.9-full/cmake/external/CMakeLists.txt
+@@ -37,7 +37,7 @@
+ add_checked_subdirectory(hunspell)
+ endif()
+ add_checked_subdirectory(iconv)
+-if (LINUX)
++if (LINUX AND NOT DESKTOP_APP_DISABLE_JEMALLOC)
+ add_checked_subdirectory(jemalloc)
+ endif()
+ add_checked_subdirectory(jpeg)
+--- tdesktop-2.8.9-full.orig/cmake/options.cmake
++++ tdesktop-2.8.9-full/cmake/options.cmake
+@@ -56,6 +56,13 @@
+ )
+ endif()
+
++if (DESKTOP_APP_DISABLE_JEMALLOC)
++ target_compile_definitions(common_options
++ INTERFACE
++ DESKTOP_APP_DISABLE_JEMALLOC
++ )
++endif()
++
+ if (DESKTOP_APP_USE_PACKAGED)
+ target_compile_definitions(common_options
+ INTERFACE
+--- tdesktop-2.8.9-full.orig/cmake/options_linux.cmake
++++ tdesktop-2.8.9-full/cmake/options_linux.cmake
+@@ -58,10 +58,12 @@
+ endif()
+ endif()
+
+-target_link_libraries(common_options
+-INTERFACE
+- desktop-app::external_jemalloc
+-)
++if (NOT DESKTOP_APP_DISABLE_JEMALLOC)
++ target_link_libraries(common_options
++ INTERFACE
++ desktop-app::external_jemalloc
++ )
++endif()
+
+ if (DESKTOP_APP_USE_PACKAGED)
+ find_library(ATOMIC_LIBRARY atomic)
+--- tdesktop-2.8.9-full.orig/cmake/variables.cmake
++++ tdesktop-2.8.9-full/cmake/variables.cmake
+@@ -38,6 +38,7 @@
+ option(DESKTOP_APP_USE_PACKAGED_FFMPEG_STATIC "Link ffmpeg statically in packaged mode." OFF)
+ option(DESKTOP_APP_DISABLE_SPELLCHECK "Disable spellcheck library." ${osx_special_target})
+ option(DESKTOP_APP_DISABLE_WEBKIT "Disable WebkitGTK library (Linux only)." OFF)
++option(DESKTOP_APP_DISABLE_JEMALLOC "Disable use of the jemalloc allocator (Linux only)." OFF)
+ option(DESKTOP_APP_DISABLE_CRASH_REPORTS "Disable crash report generation." ${no_special_target})
+ option(DESKTOP_APP_DISABLE_AUTOUPDATE "Disable autoupdate." ${disable_autoupdate})
+ option(DESKTOP_APP_USE_HUNSPELL_ONLY "Disable system spellchecker and use bundled Hunspell only. (For debugging purposes)" OFF)
diff --git a/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch
new file mode 100644
index 000000000000..388e09fa58d2
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch
@@ -0,0 +1,122 @@
+Allow controlling the use of webkit-gtk
+
+WebKitGTK is used to display payment pages when buying things in Telegram
+shops. This library can be disabled properly alongside the GTK integration with
+its flag. However, I reckon *most* users want the GTK integration (fixes
+pasting big images, amongst other things), but hardly anyone actually buys
+things through Telegram. Controlling these two things separately is trivial, and
+the user gets a nice dialog telling them WebKitGTK isn't available in the event
+they *do* attempt to use the related features.
+
+NOTE: GTK integration *must* be enabled for WebKitGTK to work.
+
+--- tdesktop-2.8.9-full.orig/Telegram/SourceFiles/platform/linux/linux_gtk_integration.cpp
++++ tdesktop-2.8.9-full/Telegram/SourceFiles/platform/linux/linux_gtk_integration.cpp
+@@ -587,9 +587,11 @@
+ if (const auto integration = BaseGtkIntegration::Instance()) {
+ return integration->exec(parentDBusName);
+ }
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ } else if (type == Type::Webview) {
+ Webview::WebKit2Gtk::SetServiceName(serviceName.toStdString());
+ return Webview::WebKit2Gtk::Exec(parentDBusName.toStdString());
++#endif
+ } else if (type == Type::TDesktop) {
+ ServiceName = serviceName.toStdString();
+ if (const auto integration = Instance()) {
+@@ -602,7 +604,9 @@
+
+ void GtkIntegration::Start(Type type) {
+ if (type != Type::Base
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ && type != Type::Webview
++#endif
+ && type != Type::TDesktop) {
+ return;
+ }
+@@ -613,11 +617,13 @@
+
+ if (type == Type::Base) {
+ BaseGtkIntegration::SetServiceName(kBaseService.utf16().arg(h));
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ } else if (type == Type::Webview) {
+ Webview::WebKit2Gtk::SetServiceName(
+ kWebviewService.utf16().arg(h).arg("%1").toStdString());
+
+ return;
++#endif
+ } else {
+ ServiceName = kService.utf16().arg(h).toStdString();
+ }
+--- tdesktop-2.8.9-full.orig/Telegram/lib_webview/CMakeLists.txt
++++ tdesktop-2.8.9-full/Telegram/lib_webview/CMakeLists.txt
+@@ -48,7 +48,7 @@
+ nuget_add_webview(lib_webview)
+ nuget_add_winrt(lib_webview)
+ elseif (LINUX)
+- if (NOT DESKTOP_APP_DISABLE_GTK_INTEGRATION)
++ if (NOT DESKTOP_APP_DISABLE_WEBKIT)
+ find_package(PkgConfig REQUIRED)
+
+ if (DESKTOP_APP_USE_PACKAGED AND NOT DESKTOP_APP_USE_PACKAGED_LAZY)
+--- tdesktop-2.8.9-full.orig/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
++++ tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
+@@ -11,14 +11,14 @@
+ namespace Webview {
+
+ Available Availability() {
+-#ifndef DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ return WebKit2Gtk::Availability();
+-#else // !DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#else // !DESKTOP_APP_DISABLE_WEBKIT
+ return Available{
+ .error = Available::Error::NoGtkOrWebkit2Gtk,
+ .details = "This feature was disabled at build time.",
+ };
+-#endif // DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#endif // DESKTOP_APP_DISABLE_WEBKIT
+ }
+
+ bool SupportsEmbedAfterCreate() {
+@@ -26,11 +26,11 @@
+ }
+
+ std::unique_ptr<Interface> CreateInstance(Config config) {
+-#ifndef DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ return WebKit2Gtk::CreateInstance(std::move(config));
+-#else // !DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#else // !DESKTOP_APP_DISABLE_WEBKIT
+ return nullptr;
+-#endif // DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#endif // DESKTOP_APP_DISABLE_WEBKIT
+ }
+
+ } // namespace Webview
+--- tdesktop-2.8.9-full.orig/cmake/options.cmake
++++ tdesktop-2.8.9-full/cmake/options.cmake
+@@ -49,6 +49,13 @@
+ )
+ endif()
+
++if (DESKTOP_APP_DISABLE_WEBKIT)
++ target_compile_definitions(common_options
++ INTERFACE
++ DESKTOP_APP_DISABLE_WEBKIT
++ )
++endif()
++
+ if (DESKTOP_APP_USE_PACKAGED)
+ target_compile_definitions(common_options
+ INTERFACE
+--- tdesktop-2.8.9-full.orig/cmake/variables.cmake
++++ tdesktop-2.8.9-full/cmake/variables.cmake
+@@ -37,6 +37,7 @@
+ option(DESKTOP_APP_USE_PACKAGED_LAZY "Bundle recommended Qt plugins for self-contained packages. (Linux only)" OFF)
+ option(DESKTOP_APP_USE_PACKAGED_FFMPEG_STATIC "Link ffmpeg statically in packaged mode." OFF)
+ option(DESKTOP_APP_DISABLE_SPELLCHECK "Disable spellcheck library." ${osx_special_target})
++option(DESKTOP_APP_DISABLE_WEBKIT "Disable WebkitGTK library (Linux only)." OFF)
+ option(DESKTOP_APP_DISABLE_CRASH_REPORTS "Disable crash report generation." ${no_special_target})
+ option(DESKTOP_APP_DISABLE_AUTOUPDATE "Disable autoupdate." ${disable_autoupdate})
+ option(DESKTOP_APP_USE_HUNSPELL_ONLY "Disable system spellchecker and use bundled Hunspell only. (For debugging purposes)" OFF)
diff --git a/net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch b/net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch
new file mode 100644
index 000000000000..02c96d28b2c1
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch
@@ -0,0 +1,31 @@
+Fixes an issue with glib headers including a C++ header inside extern "C"
+
+This patch is a hacky workaround, proper solution doesn't seem trivial.
+
+In file included from /usr/include/glib-2.0/glib/gatomic.h:31,
+ from /usr/include/glib-2.0/glib/gthread.h:32,
+ from /usr/include/glib-2.0/glib/gasyncqueue.h:32,
+ from /usr/include/glib-2.0/glib.h:32,
+ from /usr/include/gtk-3.0/gdk/gdkconfig.h:13,
+ from /usr/include/gtk-3.0/gdk/gdk.h:30,
+ from /usr/include/gtk-3.0/gtk/gtk.h:30,
+ from /var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h:11,
+ from /var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.cpp:7:
+/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/include/g++-v11/type_traits:56:3: error: template with C linkage
+ 56 | template<typename _Tp, _Tp __v>
+ | ^~~~~~~~
+In file included from /var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.cpp:7:
+/var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h:9:1: note: extern "C" linkage started here
+ 9 | extern "C" {
+ | ^~~~~~~~~~
+
+--- tdesktop-2.8.9-full.orig/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
++++ tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
+@@ -6,6 +6,7 @@
+ //
+ #pragma once
+
++#include <type_traits> // Required for glib/gatomic.h
+ extern "C" {
+ #include <JavaScriptCore/JavaScript.h>
+ #include <gtk/gtk.h>