summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-logger')
-rw-r--r--net-im/telepathy-logger/Manifest2
-rw-r--r--net-im/telepathy-logger/metadata.xml5
-rw-r--r--net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild50
-rw-r--r--net-im/telepathy-logger/telepathy-logger-0.8.2.ebuild50
4 files changed, 107 insertions, 0 deletions
diff --git a/net-im/telepathy-logger/Manifest b/net-im/telepathy-logger/Manifest
new file mode 100644
index 000000000000..1e84c0b8649a
--- /dev/null
+++ b/net-im/telepathy-logger/Manifest
@@ -0,0 +1,2 @@
+DIST telepathy-logger-0.8.1.tar.bz2 569680 SHA256 359528f5fa1539b250fead8d68c7a0eaef11ed4284dfb3761fff2b6dd688da39 SHA512 8c4a8b4fc6f8d98378bfa3008bcc7d921a7bdf659144bd60827d9bdd234644738224a17e5b39099b6b3df224cad8f1d03b9fed3e25b37a14d079eb22b13d5a30 WHIRLPOOL 2fefc7f5e464e845226cae9f10a2722c887fd67e0292cc634c3f624d329cd342d0c6797a70960549e2b0393ac940b4911c62dd5ec17722dffbbbec176154f2e0
+DIST telepathy-logger-0.8.2.tar.bz2 562670 SHA256 8fcad534d653b1b365132c5b158adae947810ffbae9843f72dd1797966415dae SHA512 f3eda26133a4c38eeb79b01cbe3b7801a5eb773e8b4e6ce621c47d3ca701025364c6b2b890caea00104f01ba85ae891a6fad82d7a9dc487fd7a980221cede451 WHIRLPOOL 84aabf0f9cf594ade109f37490d999cd3f37fca894a2a659b97da4314d3aa3375c97fdad4a282208c427e8c34d81568f8298c5872c8ad9a7f213d2b00b0dfe9f
diff --git a/net-im/telepathy-logger/metadata.xml b/net-im/telepathy-logger/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-im/telepathy-logger/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild b/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild
new file mode 100644
index 000000000000..db8d1cde16b9
--- /dev/null
+++ b/net-im/telepathy-logger/telepathy-logger-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="Telepathy Logger is a session daemon that should be activated whenever telepathy is being used"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Logger"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1.1
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.19.2[introspection?]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-db/sqlite:3
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # --enable-debug needed due https://bugs.freedesktop.org/show_bug.cgi?id=83390
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-debug \
+ --enable-public-extensions \
+ --disable-coding-style-checks \
+ --disable-Werror \
+ --disable-static
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/net-im/telepathy-logger/telepathy-logger-0.8.2.ebuild b/net-im/telepathy-logger/telepathy-logger-0.8.2.ebuild
new file mode 100644
index 000000000000..6b71762d8097
--- /dev/null
+++ b/net-im/telepathy-logger/telepathy-logger-0.8.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="Telepathy Logger is a session daemon that should be activated whenever telepathy is being used"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Logger"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1.1
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.19.2[introspection?]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-db/sqlite:3
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # --enable-debug needed due to https://bugs.freedesktop.org/show_bug.cgi?id=83390
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-debug \
+ --enable-public-extensions \
+ --disable-coding-style-checks \
+ --disable-Werror \
+ --disable-static
+}
+
+src_test() {
+ Xemake check
+}