summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Manifest5
-rw-r--r--net-im/toxic/files/toxic-0.11.1-NAME_MAX-and-PATH_MAX.patch48
-rw-r--r--net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch39
-rw-r--r--net-im/toxic/metadata.xml9
-rw-r--r--net-im/toxic/toxic-0.11.1-r1.ebuild117
-rw-r--r--net-im/toxic/toxic-0.11.3-r1.ebuild117
-rw-r--r--net-im/toxic/toxic-0.8.2.ebuild99
-rw-r--r--net-im/toxic/toxic-0.8.3.ebuild84
8 files changed, 329 insertions, 189 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 2f4c4e49deba..21f2738184f9 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1,3 +1,2 @@
-DIST toxic-0.8.2.tar.gz 1146526 BLAKE2B 0a1c80313963287e88aa489ecf4614365a3d94c770cdfb3b1f3afd0bf2b70639c35b9c5ce52408647abdaac9822c9529b603ec1883779f5486ff63001d98ff5e SHA512 258e873404315c9a1f59d67f524089afebad88d800116bd9e53c8bc35bd9dd6b66cfcd90db06181f01330ba0a302456510fac5c01fdbfde7d475aa5d6b1070aa
-DIST toxic-0.8.3.tar.gz 1147100 BLAKE2B d73a861112aca65e54773c98473c2858bb81e63fef11212633e34dac9e87101956e3ab0d9d56757767bc5d48d1d5a406e550f8fc55ae34860dbc4977c94ee347 SHA512 c8d746efcc055592dd990dfa57415cc1eacaaa3b66303d7583d9f9e7e98b8829c8f1ae849f36a243c8896e99787dd2e493c92367de719b20a4a160bc7daea76e
-DIST toxic_patches-0.8.2.tar.gz 3859 BLAKE2B 4a19226cea6c7ce60f599fbd4f74171f26b3812259f0f8997997526bde7beb6fe64b922f25fe77e0ac8f9b185db116d2e626cb889631a1508786b92f9bbc8927 SHA512 737cc53e814567e10ad8b7431be63ab8f99b76bb150490c31e03309c4e51ee34a798d141cbde446cbbc4b5c0145ca468f3456a2af4b966c80792cdccc6562b46
+DIST toxic-0.11.1.tar.gz 1204163 BLAKE2B 1e388982236badf1a27cb1cfd9e84ec635be6a576a0719a7394f32ac82f23796f94236ab807180620cbfa8c0c42f43ff244d2d99d27cd5ab3258c1ce69acc545 SHA512 53fba05271020547e779d63bea777f90f56b61e3eb2775afabe92e047a8347b4a9166628bb59d2eaab2e36a1121d791206ac68ff6604cb06fac6aaddbb05e787
+DIST toxic-0.11.3.tar.gz 1197252 BLAKE2B 4a7a3c4eed270330c6d79ad400778debda1b98b66beed1196cf4e36858d300141c468c4963d012b77d8232f7b3b3b419138505e46098bfac3cde48e9bc0b0e1c SHA512 2c8408004d9644b52cbe9477d7c486622fcef52f1d10a1bcdf7555656a2f2e1bd4c6f0594a7b0b3156fd6908c470c5b41c55e6e0914c3eb2067614013f0f259f
diff --git a/net-im/toxic/files/toxic-0.11.1-NAME_MAX-and-PATH_MAX.patch b/net-im/toxic/files/toxic-0.11.1-NAME_MAX-and-PATH_MAX.patch
new file mode 100644
index 000000000000..09845d294a2e
--- /dev/null
+++ b/net-im/toxic/files/toxic-0.11.1-NAME_MAX-and-PATH_MAX.patch
@@ -0,0 +1,48 @@
+diff -ruN src/autocomplete.c src/autocomplete.c
+--- src/autocomplete.c 2021-08-09 18:52:27.090248882 -0400
++++ src/autocomplete.c 2021-08-11 14:57:39.029828530 -0400
+@@ -25,10 +25,12 @@
+ #include <string.h>
+
+ #ifdef __APPLE__
+-#include <sys/types.h>
+ #include <sys/dir.h>
++#include <sys/types.h>
++#include <sys/sysinfo.h>//This should contain PATH_MAX and NAME_MAX
+ #else
+ #include <dirent.h>
++#include <linux/limits.h>
+ #endif /* __APPLE__ */
+
+ #include "configdir.h"
+diff -ruN src/file_transfers.h src/file_transfers.h
+--- src/file_transfers.h 2021-07-26 15:39:36.765990567 -0400
++++ src/file_transfers.h 2021-08-11 14:59:41.223159195 -0400
+@@ -24,6 +24,12 @@
+ #define FILE_TRANSFERS_H
+
+ #include <limits.h>
++//This should include NAME_MAX and PATH_MAX
++#ifdef __APPLE__
++#include <sys/sysinfo.h>
++#elif __linux__
++#include <linux/limits.h>
++#endif
+
+ #include "notify.h"
+ #include "toxic.h"
+diff -ruN src/settings.h src/settings.h
+--- src/settings.h 2021-08-09 18:52:27.093582216 -0400
++++ src/settings.h 2021-08-11 15:00:46.889824433 -0400
+@@ -24,6 +24,12 @@
+ #define SETTINGS_H
+
+ #include <limits.h>
++//This should include NAME_MAX and PATH_MAX
++#ifdef __APPLE__
++#include <sys/sysinfo.h>
++#elif __linux__
++#include <linux/limits.h>
++#endif
+
+ #include <tox/tox.h>
diff --git a/net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch b/net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch
new file mode 100644
index 000000000000..2101b64e3d9f
--- /dev/null
+++ b/net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch
@@ -0,0 +1,39 @@
+diff -ruN src/autocomplete.c src/autocomplete.c
+--- src/autocomplete.c
++++ src/autocomplete.c
+@@ -29,6 +29,7 @@
+ #include <sys/dir.h>
+ #else
+ #include <dirent.h>
++#include <linux/limits.h>
+ #endif /* __APPLE__ */
+
+ #include "configdir.h"
+diff -ruN src/file_transfers.h src/file_transfers.h
+--- src/file_transfers.h
++++ src/file_transfers.h
+@@ -25,6 +25,10 @@
+
+ #include <limits.h>
+
++#ifdef __linux__
++#include <linux/limits.h>
++#endif
++
+ #include "notify.h"
+ #include "toxic.h"
+ #include "windows.h"
+diff -ruN src/settings.h src/settings.h
+--- src/settings.h
++++ src/settings.h
+@@ -25,6 +25,10 @@
+
+ #include <limits.h>
+
++#ifdef __linux__
++#include <linux/limits.h>
++#endif
++
+ #include <tox/tox.h>
+
+ /* Represents line_* hints max strlen */
diff --git a/net-im/toxic/metadata.xml b/net-im/toxic/metadata.xml
index 02e709980dad..cdcd3b5220b7 100644
--- a/net-im/toxic/metadata.xml
+++ b/net-im/toxic/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>JoMull01@protonmail.com</email>
<name>Josiah Mullins</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
@@ -20,6 +20,9 @@
An ncurses-based Tox client written in C. Supports audio and video calling, file sharing, and desktop notifications.
</longdescription>
<use>
+ <flag name="audio-notify">Enables native sound notifications</flag>
+ <flag name="games">Enables some small mini-games</flag>
+ <flag name="llvm">Enables support for LLVM Address Sanitizer</flag>
<flag name="notification">Enables desktop notifications with libnotify, with sound support.</flag>
<flag name="qrcode">Enables QR code support</flag>
<flag name="sound">Enables audio calling</flag>
diff --git a/net-im/toxic/toxic-0.11.1-r1.ebuild b/net-im/toxic/toxic-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..1a535eb7fcaa
--- /dev/null
+++ b/net-im/toxic/toxic-0.11.1-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+audio-notify debug games llvm notification png python qrcode +sound +video +X"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ video? ( sound X ) "
+
+BDEPEND="dev-libs/libconfig:=
+ virtual/pkgconfig"
+
+RDEPEND="net-libs/tox:=
+ net-misc/curl
+ sys-kernel/linux-headers
+ sys-libs/ncurses:=
+ audio-notify? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ notification? ( x11-libs/libnotify )
+ debug? ( llvm? ( sys-devel/llvm:* ) )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? (
+ media-gfx/qrencode:=
+ png? ( media-libs/libpng )
+ )
+ sound? (
+ media-libs/openal
+ net-libs/tox:=[av]
+ )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ #prevent man files from being compressed.
+ sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
+ #Fix incorrect linkage of pthread (may be optional)
+ sed -i -e 's/pthread/lpthread/g' Makefile || die "Unable to fix linking of pthread."
+ #Makefile sets some required CFLAGS only if CFLAGS variable is undefined,
+ #This line changes the "lazy set if absent" assignment to a "lazy set" assignment.
+ #look below in src_configure to see how CFLAGS are passed to the makefile in USER_CFLAGS
+ sed -i -e 's/?=/=/g' Makefile || die "Unable to change assignment of CFLAGS and LDFLAGS"
+ #Fix incomplete invocation of python-config
+ sed -i -e "s/--ldflags/--ldflags --embed/" cfg/checks/python.mk || die "Unable to fix python linking"
+ #This is to fix incorrect include statements of NAME_MAX and PATH_MAX macros
+ eapply -p0 "${FILESDIR}/${P}-NAME_MAX-and-PATH_MAX.patch" || die "Unable to fix include statements"
+}
+
+src_configure() {
+ if ! use audio-notify; then
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if use debug; then
+ export ENABLE_RELEASE=0
+ if use llvm; then
+ export ENABLE_ASAN=1
+ fi
+ fi
+ if ! use games; then
+ export DISABLE_GAMES=1
+ fi
+ if ! use notification; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ if ! use png; then
+ export DISABLE_QRPNG=1
+ fi
+ if use python; then
+ export ENABLE_PYTHON=1
+ fi
+ if ! use qrcode; then
+ export DISABLE_QRCODE=1
+ fi
+ if ! use sound; then
+ export DISABLE_AV=1
+ fi
+ if ! use video; then
+ export DISABLE_VI=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ #include strings.h fixes undefined reference to strcasecmp()
+ #defining _GNU_SOURCE fixes undefined reference to strcasestr()
+ export USER_CFLAGS="${CFLAGS} -include strings.h -D _GNU_SOURCE"
+ export USER_LDFLAGS="${LDFLAGS}"
+ #set install directory to /usr.
+ sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
+}
+
+src_install() {
+ default
+ if ! use audio-notify; then
+ rm -r "${ED}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}
diff --git a/net-im/toxic/toxic-0.11.3-r1.ebuild b/net-im/toxic/toxic-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..729b32f3fcc0
--- /dev/null
+++ b/net-im/toxic/toxic-0.11.3-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+audio-notify debug games llvm notification png python qrcode +sound +video +X"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ video? ( sound X ) "
+
+BDEPEND="dev-libs/libconfig:=
+ virtual/pkgconfig"
+
+RDEPEND="net-libs/tox:=
+ net-misc/curl
+ sys-kernel/linux-headers
+ sys-libs/ncurses:=
+ audio-notify? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ notification? ( x11-libs/libnotify )
+ debug? ( llvm? ( sys-devel/llvm:* ) )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? (
+ media-gfx/qrencode:=
+ png? ( media-libs/libpng )
+ )
+ sound? (
+ media-libs/openal
+ net-libs/tox:=[av]
+ )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ #prevent man files from being compressed.
+ sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
+ #Fix incorrect linkage of pthread (may be optional)
+ sed -i -e 's/pthread/lpthread/g' Makefile || die "Unable to fix linking of pthread."
+ #Makefile sets some required CFLAGS only if CFLAGS variable is undefined,
+ #This line changes the "lazy set if absent" assignment to a "lazy set" assignment.
+ #look below in src_configure to see how CFLAGS are passed to the makefile in USER_CFLAGS
+ sed -i -e 's/?=/=/g' Makefile || die "Unable to change assignment of CFLAGS and LDFLAGS"
+ #Fix incomplete invocation of python-config
+ sed -i -e "s/--ldflags/--ldflags --embed/" cfg/checks/python.mk || die "Unable to fix python linking"
+ #This is to fix incorrect include statements of NAME_MAX and PATH_MAX macros
+ eapply -p0 "${FILESDIR}/${P}-NAME_MAX-and-PATH_MAX.patch" || die "Unable to fix include statements"
+}
+
+src_configure() {
+ if ! use audio-notify; then
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if use debug; then
+ export ENABLE_RELEASE=0
+ if use llvm; then
+ export ENABLE_ASAN=1
+ fi
+ fi
+ if ! use games; then
+ export DISABLE_GAMES=1
+ fi
+ if ! use notification; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ if ! use png; then
+ export DISABLE_QRPNG=1
+ fi
+ if use python; then
+ export ENABLE_PYTHON=1
+ fi
+ if ! use qrcode; then
+ export DISABLE_QRCODE=1
+ fi
+ if ! use sound; then
+ export DISABLE_AV=1
+ fi
+ if ! use video; then
+ export DISABLE_VI=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ #Including strings.h fixes undefined reference to strcasecmp()
+ #Defining _GNU_SOURCE fixes undefined reference to strcasestr()
+ export USER_CFLAGS="${CFLAGS} -include strings.h -D _GNU_SOURCE"
+ export USER_LDFLAGS="${LDFLAGS}"
+ #set install directory to /usr.
+ sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
+}
+
+src_install() {
+ default
+ if ! use audio-notify; then
+ rm -r "${ED}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}
diff --git a/net-im/toxic/toxic-0.8.2.ebuild b/net-im/toxic/toxic-0.8.2.ebuild
deleted file mode 100644
index b6312da26f72..000000000000
--- a/net-im/toxic/toxic-0.8.2.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit python-single-r1 xdg
-
-DESCRIPTION="A curses-based client for Tox"
-HOMEPAGE="https://github.com/JFreegman/toxic"
-SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/fx-carton/toxic_patches/archive/v${PV}.tar.gz -> ${PN}_patches-${PV}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X +sound notification +python +qrcode +video"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Not a typo; net-libs/tox only has a 'both or neither' option
-RDEPEND="
- net-libs/tox:0/0.2
- dev-libs/libconfig
- net-misc/curl:0=
- sys-libs/ncurses:0=
- notification? ( x11-libs/libnotify )
- python? ( ${PYTHON_DEPS} )
- qrcode? ( media-gfx/qrencode:= )
- sound? (
- media-libs/openal
- media-libs/freealut
- net-libs/tox:0/0.2[av]
- )
- video? (
- media-libs/libvpx:=
- net-libs/tox:0/0.2[av]
- x11-libs/libX11
- )
-"
-DEPEND="
- virtual/pkgconfig
- ${RDEPEND}
-"
-
-PATCHES=(
- "${WORKDIR}/${PN}_patches-${PV}/${P}-make-qrencode-optional.patch"
- )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- if [[ ${PV} = 0.8.2 ]]; then
- sed -i \
- -e 's/^\(TOXIC_VERSION =\).*$/\1 0.8.2/' \
- cfg/global_vars.mk || die
- else
- die "Remove stale version hack"
- fi
- sed -i '/^VIDEO = /s/DISABLE_AV/DISABLE_VI/g' cfg/checks/check_features.mk || die
- find . '(' -name '*.mk' -o -name 'Makefile' ')' -exec sed -i 's/^\t@/\t/' {} + || die
-}
-
-src_configure() {
- export USER_CFLAGS="${CFLAGS}"
- export USER_LDFLAGS="${LDFLAGS}"
- if ! use sound; then
- export DISABLE_AV=1
- export DISABLE_SOUND_NOTIFY=1
- fi
- if ! use video; then
- export DISABLE_VI=1
- fi
- if ! use X; then
- export DISABLE_X11=1
- fi
- if ! use notification; then
- export DISABLE_DESKTOP_NOTIFY=1
- fi
- if ! use qrcode; then
- export DISABLE_QRCODE=1
- export DISABLE_QRPNG=1
- fi
- if use python; then
- export ENABLE_PYTHON=1
- fi
- sed -i \
- -e "s,/usr/local,${EPREFIX}/usr,g" \
- cfg/global_vars.mk || die "PREFIX sed failed"
-}
-
-src_install() {
- default
- if ! use sound; then
- rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
- fi
-}
diff --git a/net-im/toxic/toxic-0.8.3.ebuild b/net-im/toxic/toxic-0.8.3.ebuild
deleted file mode 100644
index a39f3e6f1ce6..000000000000
--- a/net-im/toxic/toxic-0.8.3.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit python-single-r1 xdg
-
-DESCRIPTION="A curses-based client for Tox"
-HOMEPAGE="https://github.com/JFreegman/toxic"
-SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="notification python qrcode +sound +video +X"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/libconfig
- >=net-libs/tox-0.2.8:*
- net-misc/curl
- sys-libs/ncurses:*
- notification? ( x11-libs/libnotify )
- python? ( ${PYTHON_DEPS} )
- qrcode? ( media-gfx/qrencode )
- sound? (
- media-libs/freealut
- media-libs/openal
- net-libs/tox[av]
- )
- video? (
- media-libs/libvpx
- net-libs/tox[av]
- x11-libs/libX11 )"
-
-DEPEND="
- virtual/pkgconfig
- ${RDEPEND}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- #prevent man files from being compressed.
- sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
-}
-
-src_configure() {
- export USER_CFLAGS="${CFLAGS}"
- export USER_LDFLAGS="${LDFLAGS}"
- if ! use sound; then
- export DISABLE_AV=1
- export DISABLE_SOUND_NOTIFY=1
- fi
- if ! use video; then
- export DISABLE_VI=1
- fi
- if ! use X; then
- export DISABLE_X11=1
- fi
- if ! use notification; then
- export DISABLE_DESKTOP_NOTIFY=1
- fi
- if ! use qrcode; then
- export DISABLE_QRCODE=1
- export DISABLE_QRPNG=1
- fi
- if use python; then
- export ENABLE_PYTHON=1
- fi
- #set install directory to /usr.
- sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
-}
-
-src_install() {
- default
- if ! use sound; then
- rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
- fi
-}