summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/tokodon/Manifest1
-rw-r--r--net-im/tokodon/files/tokodon-23.04.0-tokodon-not-neochat.patch47
-rw-r--r--net-im/tokodon/tokodon-23.04.0.ebuild50
3 files changed, 98 insertions, 0 deletions
diff --git a/net-im/tokodon/Manifest b/net-im/tokodon/Manifest
index c77c2e2d416b..ad5af97534f9 100644
--- a/net-im/tokodon/Manifest
+++ b/net-im/tokodon/Manifest
@@ -1 +1,2 @@
DIST tokodon-23.03.90.tar.xz 226728 BLAKE2B a30323b4239c6a3f61a99d25482fb6171ddd065ba69a15d100a4b02f29b526be94f8dc73c8137f48d976646c602f1ae7e57acc0784d854a47f9dabf937a70589 SHA512 237531eb46668905cc0cb797c312379cd10fc513403f028f00b1230fe4761e173f67c736a6bb4c8811925480adc0105a6fca1be61a1240b37dae655bb63fa1d8
+DIST tokodon-23.04.0.tar.xz 229524 BLAKE2B a2b17f8c93f323fd17d6b54a742a6e73fb9b87b56e952852e98438bbc30ba771b4f2c1cb771137073596e5eb8efab076fd0924fdd46f1cb095b8e75a785cdbd1 SHA512 230432ee9761ce2655313a6e4de9719c6973de5309575b0fec365d0f6e013835cdf78782566a2c61e7972f3d6c71b8f65cd06c723367cc9681103b5d69f626f5
diff --git a/net-im/tokodon/files/tokodon-23.04.0-tokodon-not-neochat.patch b/net-im/tokodon/files/tokodon-23.04.0-tokodon-not-neochat.patch
new file mode 100644
index 000000000000..e9ec12d64a99
--- /dev/null
+++ b/net-im/tokodon/files/tokodon-23.04.0-tokodon-not-neochat.patch
@@ -0,0 +1,47 @@
+From bc361013894ebd1a56f3d9b64da2da730e9487ca Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 20 Apr 2023 20:08:45 +0200
+Subject: [PATCH] Fix obvious copy/paste mistakes
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/abstractaccount.cpp | 4 ++--
+ src/networkcontroller.cpp | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/abstractaccount.cpp b/src/abstractaccount.cpp
+index b3f75444..5fb4d458 100644
+--- a/src/abstractaccount.cpp
++++ b/src/abstractaccount.cpp
+@@ -175,7 +175,7 @@ void AbstractAccount::setInstanceUri(const QString &instance_uri)
+ instance_url.setScheme("https"); // getting token from http is not supported
+
+ m_instance_uri = instance_url.toString();
+- registerApplication("Tokodon", "https://app.kde.org/neochat");
++ registerApplication("Tokodon", "https://apps.kde.org/tokodon");
+ }
+
+ QString AbstractAccount::instanceUri() const
+@@ -488,4 +488,4 @@ bool AbstractAccount::isRegistered() const
+ QString AbstractAccount::settingsGroupName() const
+ {
+ return m_name + QLatin1Char('@') + QUrl(m_instance_uri).host();
+-}
+\ No newline at end of file
++}
+diff --git a/src/networkcontroller.cpp b/src/networkcontroller.cpp
+index 677e45c1..58a43cbb 100644
+--- a/src/networkcontroller.cpp
++++ b/src/networkcontroller.cpp
+@@ -33,7 +33,7 @@ void NetworkController::setApplicationProxy()
+ Config *cfg = Config::self();
+ QNetworkProxy proxy;
+
+- // type match to ProxyType from neochatconfig.kcfg
++ // type match to ProxyType from config.kcfg
+ switch (cfg->proxyType()) {
+ case 1: // HTTP
+ proxy.setType(QNetworkProxy::HttpProxy);
+--
+GitLab
+
diff --git a/net-im/tokodon/tokodon-23.04.0.ebuild b/net-im/tokodon/tokodon-23.04.0.ebuild
new file mode 100644
index 000000000000..9dcc662206ec
--- /dev/null
+++ b/net-im/tokodon/tokodon-23.04.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.104.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Mastodon client for Plasma and Plasma Mobile"
+HOMEPAGE="https://apps.kde.org/tokodon/"
+
+LICENSE="CC-BY-SA-4.0 GPL-2+ GPL-3+ || ( LGPL-2.1+ LGPL-3+ ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/kirigami-addons-0.7.2:5
+ dev-libs/qtkeychain:=[qt5(+)]
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwebsockets-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5[qml]
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5[qml]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-tokodon-not-neochat.patch" ) # git master
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ ecm_src_test
+}