summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/profanity-0.14.0-r2.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 626af351c308..9726decea4da 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,4 +1,5 @@
DIST profanity-0.13.1.tar.xz 621836 BLAKE2B e038fa01272150cb7974b03f88f64335bf1690115dbbb1c6fe04c79acb69db18c556edf41316af1d363f9715cd2e7aeb3f3bd867836704b620d9a87976b64fa9 SHA512 6d7d3c96c65e26c15cac1157bd296c1dbd3e2471aec959d6c319c68b70ec21cef0c40d7b4eed40c30c377a766db9f13a774ccb4880c227ee368e4dd607d9c267
DIST profanity-0.14.0-ox-carbons.patch 1525 BLAKE2B 85fe9a76a8c735047365d56555c8e1df7906b5a676740a165fc5d9eab3933124b58abf6bdd0b448b5030a51cd1fad3ce8627cc03a2fbdacdd20c5dcc71d194e1 SHA512 36cfbb12ef7889ae5f318e35da2b0edf39dca067cefb9ac921f27cba0f52746eaae9d65b7631be392dd6e9a15d1fc8f8a3de36efe8707c756e9b008291e7f55e
+DIST profanity-0.14.0-plugins-install.patch 2295 BLAKE2B 8b67718abdb620875b9040f550685189acf5a2776aa5f45422e3471c13ae05bd773c05652048940d5b8d10d88c9a013c3262742db7c84b0ff0c108f5f78ead45 SHA512 a8912d5a33d4d6eebf85733f616ed729a05688b4acf70c927aa733755527fd4e523c3a485bbb0390b2006225e8420e1d76db7e91d2122af41496c0081e3b0cea
DIST profanity-0.14.0-xscreensaver.patch 1678 BLAKE2B fe350b2249e45224b6510bb5730f38eafeb47e60a44035eaf88771940c9f0e556cc72ca737cb68c0b148b9faff442b9c9b6cdf9169a3db7ff6c7a60c2bdfc025 SHA512 2875df728b9957fc3bc8734a87c0e1a48913170b9718d6664ea65187327e26da1a7b2f5b80fe243a5ce5ab74983e4f3d22113747f44f8b8e8c13c871d31cf651
DIST profanity-0.14.0.tar.gz 936272 BLAKE2B ec2ae625950a838ee50d6d3a87910bec76f28777bd662e909f394f18c277662694611a59d3be6c7f66821c2800a94b08f94b27a68d82e4de33b7d2f7b14ddf18 SHA512 25afd2f3146e6ed9f573f0e073cad0f06f7f8a21441c3c2c61641442d1aa5b9a7a817cdccc17354b32045ab9a965a95495a30c49088577a5060e8969725ea86e
diff --git a/net-im/profanity/profanity-0.14.0-r2.ebuild b/net-im/profanity/profanity-0.14.0-r2.ebuild
new file mode 100644
index 000000000000..7dbb1f1b992a
--- /dev/null
+++ b/net-im/profanity/profanity-0.14.0-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit python-single-r1
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="
+ https://github.com/profanity-im/profanity/releases/download/${PV}/${P}.tar.gz
+ https://github.com/profanity-im/profanity/commit/122434a.patch
+ -> ${PN}-0.14.0-ox-carbons.patch
+ https://github.com/profanity-im/profanity/commit/2ed6211c.patch
+ -> ${PN}-0.14.0-xscreensaver.patch
+ https://github.com/profanity-im/profanity/commit/b8817470.patch
+ -> ${PN}-0.14.0-plugins-install.patch
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="libnotify omemo omemo-qrcode otr gpg test xscreensaver python"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="omemo-qrcode? ( omemo ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ >=dev-libs/libstrophe-0.12.3:=
+ media-libs/harfbuzz:=
+ net-misc/curl
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/readline:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-misc/shared-mime-info
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ omemo? (
+ dev-libs/libgcrypt:=
+ net-libs/libsignal-protocol-c
+ )
+ omemo-qrcode? ( media-gfx/qrencode:= )
+ otr? ( net-libs/libotr )
+ python? ( ${PYTHON_DEPS} )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${DISTDIR}/${PN}-0.14.0-ox-carbons.patch"
+ "${DISTDIR}/${PN}-0.14.0-xscreensaver.patch"
+ "${DISTDIR}/${PN}-0.14.0-plugins-install.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-gdk-pixbuf
+ $(use_enable libnotify notifications)
+ $(use_enable omemo)
+ $(use_enable omemo-qrcode)
+ $(use_enable otr)
+ $(use_enable python python-plugins)
+ $(use_enable gpg pgp)
+ $(use_with xscreensaver)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}