summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/cgiirc/cgiirc-0.5.10.ebuild')
-rw-r--r--net-irc/cgiirc/cgiirc-0.5.10.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-irc/cgiirc/cgiirc-0.5.10.ebuild b/net-irc/cgiirc/cgiirc-0.5.10.ebuild
new file mode 100644
index 000000000000..d8b4f632a373
--- /dev/null
+++ b/net-irc/cgiirc/cgiirc-0.5.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit webapp eutils
+
+DESCRIPTION="A perl/CGI program to use IRC from a web browser"
+HOMEPAGE="http://cgiirc.org/"
+SRC_URI="http://cgiirc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ elog "Note that file locations have changed."
+ elog "CGI:IRC will be installed into cgi-bin/${P}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="README cgiirc.config.full ipaccess.example"
+
+ dodoc docs/{CHANGES,TODO} ${docs}
+ dohtml docs/help.html
+ rm -rf docs/ ${docs}
+
+ insinto "${MY_CGIBINDIR}"/${P}
+ doins -r .
+ fperms +x "${MY_CGIBINDIR}"/${P}/irc.cgi
+
+ webapp_configfile "${MY_CGIBINDIR}"/${P}/cgiirc.config
+ webapp_src_install
+}