summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild')
-rw-r--r--net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild
new file mode 100644
index 000000000000..a5dae0b018d5
--- /dev/null
+++ b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20220803.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="0d257df7d63d24610462ad611555741d7655daa9"
+
+DESCRIPTION="supybot ban management and channel flood/spam/repeat protections plugin"
+HOMEPAGE="https://github.com/ncoevoet/ChanTracker"
+SRC_URI="https://github.com/ncoevoet/ChanTracker/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS="README.md"
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ncoevoet/ChanTracker
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ncoevoet"
+}