summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild')
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild b/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild
new file mode 100644
index 000000000000..be9de0a91db5
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+S=${WORKDIR}/${P/_*/}
+
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="ftp://qoop.org/ninja/stable/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ncurses ipv6 ssl"
+
+RESTRICT="test"
+
+DEPEND="ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/bin/ninja{,_irc} || die #436804
+}