summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/pisg')
-rw-r--r--net-irc/pisg/pisg-0.73-r1.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/net-irc/pisg/pisg-0.73-r1.ebuild b/net-irc/pisg/pisg-0.73-r1.ebuild
index 4a1954fff342..e440a36c0925 100644
--- a/net-irc/pisg/pisg-0.73-r1.ebuild
+++ b/net-irc/pisg/pisg-0.73-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit perl-module
@@ -13,22 +13,17 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-
RDEPEND="dev-perl/Text-Iconv"
-DEPEND=">=sys-apps/sed-4"
src_prepare() {
+ default
+
sed -i \
-e 's!lang\.txt!/usr/share/pisg/lang.txt!' \
-e 's!layout/!/usr/share/pisg/layout/!' \
modules/Pisg.pm || die "sed failed"
}
-src_compile() {
- einfo "Nothing to compile"
-}
-
src_install() {
perl_set_version
@@ -43,7 +38,9 @@ src_install() {
dodoc docs/{FORMATS,pisg-doc.txt} \
docs/dev/API pisg.cfg README
doman docs/pisg.1
- dohtml docs/pisg-doc.html
+
+ docinto html
+ dodoc docs/pisg-doc.html
}
pkg_postinst() {