summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/quassel/quassel-9999.ebuild')
-rw-r--r--net-irc/quassel/quassel-9999.ebuild83
1 files changed, 40 insertions, 43 deletions
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index 68d94a9e3ea2..c8177a7e394e 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,8 +7,12 @@ inherit cmake xdg-utils pax-utils systemd
if [[ ${PV} != *9999* ]]; then
MY_P=${PN}-${PV/_/-}
- SRC_URI="https://quassel-irc.org/pub/${MY_P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~sparc-solaris"
+ if [[ ${PV} == *_rc* ]] ; then
+ SRC_URI="https://github.com/quassel/quassel/archive/refs/tags/${PV/_/-}.tar.gz"
+ else
+ SRC_URI="https://quassel-irc.org/pub/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~sparc-solaris"
+ fi
S="${WORKDIR}/${MY_P}"
else
EGIT_REPO_URI=( "https://github.com/${PN}/${PN}" )
@@ -17,23 +21,22 @@ fi
DESCRIPTION="Qt/KDE IRC client supporting a remote daemon for 24/7 connectivity"
HOMEPAGE="https://quassel-irc.org/"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="bundled-icons crypt +dbus debug kde ldap monolithic oxygen postgres +server
-snorenotify syslog urlpreview X"
+IUSE="bundled-icons crypt +dbus debug kde ldap monolithic oxygen postgres +server snorenotify syslog test urlpreview X"
+# Can't seem to find itself (libraries)
+RESTRICT="!test? ( test ) test"
-SERVER_DEPEND="
- acct-group/quassel
+SERVER_DEPEND="acct-group/quassel
acct-user/quassel
+ dev-qt/qtscript:5
crypt? ( app-crypt/qca:2[ssl] )
ldap? ( net-nds/openldap )
postgres? ( dev-qt/qtsql:5[postgres] )
!postgres? ( dev-qt/qtsql:5[sqlite] dev-db/sqlite:3[threadsafe(+),-secure-delete] )
- syslog? ( virtual/logger )
-"
-
-GUI_DEPEND="
- dev-qt/qtgui:5
+ syslog? ( virtual/logger )"
+GUI_DEPEND="dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtwidgets:5
!bundled-icons? (
@@ -55,10 +58,8 @@ GUI_DEPEND="
kde-frameworks/sonnet:5
)
snorenotify? ( >=x11-libs/snorenotify-0.7.0 )
- urlpreview? ( dev-qt/qtwebengine:5[widgets] )
-"
-
-RDEPEND="
+ urlpreview? ( dev-qt/qtwebengine:5[widgets] )"
+DEPEND=">=dev-libs/boost-1.54:=
dev-qt/qtcore:5
dev-qt/qtnetwork:5[ssl]
sys-libs/zlib
@@ -69,30 +70,24 @@ RDEPEND="
!monolithic? (
server? ( ${SERVER_DEPEND} )
X? ( ${GUI_DEPEND} )
- )
-"
-DEPEND="${RDEPEND}
- dev-libs/boost
-"
-BDEPEND="
- dev-qt/linguist-tools:5
- kde-frameworks/extra-cmake-modules:5
-"
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules:5"
DOCS=( AUTHORS ChangeLog README.md )
-REQUIRED_USE="
- || ( X server monolithic )
+REQUIRED_USE="|| ( X server monolithic )
crypt? ( || ( server monolithic ) )
kde? ( || ( X monolithic ) dbus )
ldap? ( || ( server monolithic ) )
postgres? ( || ( server monolithic ) )
snorenotify? ( || ( X monolithic ) )
- syslog? ( || ( server monolithic ) )
-"
+ syslog? ( || ( server monolithic ) )"
src_configure() {
local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
-DUSE_CCACHE=OFF
-DCMAKE_SKIP_RPATH=ON
-DEMBED_DATA=OFF
@@ -110,7 +105,7 @@ src_configure() {
-DWANT_QTCLIENT=$(usex X)
)
- if use server || use monolithic; then
+ if use server || use monolithic ; then
mycmakeargs+=( $(cmake_use_find_package crypt Qca-qt5) )
fi
@@ -120,28 +115,28 @@ src_configure() {
src_install() {
cmake_src_install
- if use server; then
- # needs PAX marking wrt bug#346255
- pax-mark m "${ED}/usr/bin/quasselcore"
+ if use server ; then
+ # Needs PaX marking, bug #346255
+ pax-mark m "${ED}"/usr/bin/quasselcore
- # init scripts & systemd unit
+ # Init scripts & systemd unit
newinitd "${FILESDIR}"/quasselcore.init-r1 quasselcore
newconfd "${FILESDIR}"/quasselcore.conf-r1 quasselcore
systemd_dounit "${FILESDIR}"/quasselcore.service
# logrotate
insinto /etc/logrotate.d
- newins "${FILESDIR}/quassel.logrotate" quassel
+ newins "${FILESDIR}"/quassel.logrotate quassel
fi
}
pkg_postinst() {
- if use monolithic; then
+ if use monolithic ; then
elog "Information on how to enable SSL support for client/core connections"
elog "is available at http://bugs.quassel-irc.org/projects/quassel-irc/wiki/Client-Core_SSL_support."
fi
- if use server; then
+ if use server ; then
einfo "If you want to generate SSL certificate remember to run:"
einfo " emerge --config =${CATEGORY}/${PF}"
fi
@@ -159,15 +154,17 @@ pkg_postrm() {
}
pkg_config() {
- if use server; then
- # generate the pem file only when it does not already exist
- QUASSEL_DIR=/var/lib/${PN}
- if [ ! -f "${QUASSEL_DIR}/quasselCert.pem" ]; then
- einfo "Generating QUASSEL SSL certificate to: \"${QUASSEL_DIR}/quasselCert.pem\""
+ if use server ; then
+ # Generate the pem file only when it does not already exist
+ QUASSEL_DIR="${EROOT}"/var/lib/${PN}
+
+ if [[ ! -f "${QUASSEL_DIR}/quasselCert.pem" ]] ; then
+ einfo "Generating Quassel SSL certificate to: \"${QUASSEL_DIR}/quasselCert.pem\""
openssl req -x509 -nodes -days 365 -newkey rsa:2048 \
-keyout "${QUASSEL_DIR}/quasselCert.pem" \
-out "${QUASSEL_DIR}/quasselCert.pem"
- # permissions for the key
+
+ # Permissions for the key
chown ${PN}:${PN} "${QUASSEL_DIR}/quasselCert.pem"
chmod 400 "${QUASSEL_DIR}/quasselCert.pem"
else