summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/sic/sic-1.1.ebuild')
-rw-r--r--net-irc/sic/sic-1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-irc/sic/sic-1.1.ebuild b/net-irc/sic/sic-1.1.ebuild
new file mode 100644
index 000000000000..7cfe093ba549
--- /dev/null
+++ b/net-irc/sic/sic-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="http://tools.suckless.org/sic"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e "s/-s //g" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}