summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/sic/sic-1.2-r1.ebuild')
-rw-r--r--net-irc/sic/sic-1.2-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-irc/sic/sic-1.2-r1.ebuild b/net-irc/sic/sic-1.2-r1.ebuild
index 42dfb660ec7b..8ca301bc99ac 100644
--- a/net-irc/sic/sic-1.2-r1.ebuild
+++ b/net-irc/sic/sic-1.2-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit toolchain-funcs
-DESCRIPTION="An extremly simple IRC client"
+DESCRIPTION="An extremely simple IRC client"
HOMEPAGE="https://tools.suckless.org/sic"
SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
@@ -12,6 +13,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2-include-path.patch"
+ "${FILESDIR}/${PN}-1.2-musl-time-include.patch"
+)
+
src_prepare() {
default
@@ -30,5 +36,5 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
+ emake DESTDIR="${ED}" PREFIX="/usr" install
}