summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/znc-palaver/files')
-rw-r--r--net-irc/znc-palaver/files/znc-palaver-1.2.1-python310.patch48
-rw-r--r--net-irc/znc-palaver/files/znc-palaver-1.2.1-xunit2.patch23
2 files changed, 71 insertions, 0 deletions
diff --git a/net-irc/znc-palaver/files/znc-palaver-1.2.1-python310.patch b/net-irc/znc-palaver/files/znc-palaver-1.2.1-python310.patch
new file mode 100644
index 000000000000..79e06f30a5ef
--- /dev/null
+++ b/net-irc/znc-palaver/files/znc-palaver-1.2.1-python310.patch
@@ -0,0 +1,48 @@
+From 3d5a1a3c2a7cb3de82c618b1e70618195ec4a1e7 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Fri, 28 Aug 2020 23:48:23 +0200
+Subject: [PATCH] test/test_palaver.py: loop argument is deprecated
+
+DeprecationWarning: The loop argument is deprecated since Python 3.8,
+and scheduled for removal in Python 3.10.
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ test/test_palaver.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/test/test_palaver.py b/test/test_palaver.py
+index 1b27878..d22366a 100644
+--- a/test/test_palaver.py
++++ b/test/test_palaver.py
+@@ -50,10 +50,10 @@ async def setUp(event_loop):
+ running_as_root = os.getuid() == 0
+ allow_root = ' --allow-root' if running_as_root else ''
+
+- proc = await asyncio.create_subprocess_shell(f'znc -d test/fixtures --foreground --debug{allow_root}', loop=event_loop)
++ proc = await asyncio.create_subprocess_shell(f'znc -d test/fixtures --foreground --debug{allow_root}')
+ time.sleep(31 if running_as_root else 1)
+
+- (reader, writer) = await asyncio.open_connection('localhost', 6698, loop=event_loop)
++ (reader, writer) = await asyncio.open_connection('localhost', 6698)
+ writer.write(b'CAP LS 302\r\n')
+
+ line = await reader.readline()
+@@ -184,7 +184,7 @@ async def connected(reader, writer):
+
+ connected.called = True
+
+- server = await asyncio.start_server(connected, host='127.0.0.1', port=0, loop=event_loop)
++ server = await asyncio.start_server(connected, host='127.0.0.1', port=0)
+ await asyncio.sleep(0.2)
+ addr = server.sockets[0].getsockname()
+ url = f'Serving on http://{addr[0]}:{addr[1]}/push'
+@@ -248,7 +248,7 @@ async def connected(reader, writer):
+
+ connected.called = True
+
+- server = await asyncio.start_server(connected, host='127.0.0.1', port=0, loop=event_loop)
++ server = await asyncio.start_server(connected, host='127.0.0.1', port=0)
+ await asyncio.sleep(0.2)
+ addr = server.sockets[0].getsockname()
+ url = f'Serving on http://{addr[0]}:{addr[1]}/push'
diff --git a/net-irc/znc-palaver/files/znc-palaver-1.2.1-xunit2.patch b/net-irc/znc-palaver/files/znc-palaver-1.2.1-xunit2.patch
new file mode 100644
index 000000000000..ffbb2ad4543b
--- /dev/null
+++ b/net-irc/znc-palaver/files/znc-palaver-1.2.1-xunit2.patch
@@ -0,0 +1,23 @@
+From 3be5f33d76d4e34b1bc2671f7dbbc6c5fc3ccadd Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Sat, 29 Aug 2020 00:06:53 +0200
+Subject: [PATCH] Makefile: use xunit2 as default for pytest
+
+PytestDeprecationWarning: The 'junit_family' default
+value will change to 'xunit2' in pytest 6.0.
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index d5d4866..e88277e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -30,4 +30,4 @@ test/fixtures/modules/palaver.so: palaver.so
+ .PHONY: test-integration
+ test-integration: test/fixtures/modules/palaver.so
+ @mkdir -p test-reports
+- pytest --junitxml=test-reports/junit.xml
++ pytest -o junit_family=xunit2 --junitxml=test-reports/junit.xml