summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bnc/bnc-2.9.4-r3.ebuild (renamed from net-irc/bnc/bnc-2.9.4-r2.ebuild)12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-irc/bnc/bnc-2.9.4-r2.ebuild b/net-irc/bnc/bnc-2.9.4-r3.ebuild
index 15f92bbc17b2..c13e65bd1123 100644
--- a/net-irc/bnc/bnc-2.9.4-r2.ebuild
+++ b/net-irc/bnc/bnc-2.9.4-r3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools flag-o-matic
+
MY_P="${P/-/}"
DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
HOMEPAGE="http://gotbnc.com/"
@@ -25,11 +27,19 @@ PATCHES=(
src_prepare() {
default
+
sed -i -e 's:./mkpasswd:/usr/bin/bncmkpasswd:' bncsetup \
|| die 'failed to rename mkpasswd in bncsetup'
+
+ # bug #900076
+ eautoreconf
}
src_configure() {
+ # bug #861374
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf $(use_with ssl)
}