summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/czmq/czmq-2.2.0-r2.ebuild')
-rw-r--r--net-libs/czmq/czmq-2.2.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/czmq/czmq-2.2.0-r2.ebuild b/net-libs/czmq/czmq-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..052e84f1939f
--- /dev/null
+++ b/net-libs/czmq/czmq-2.2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION=" High-level C Binding for ZeroMQ"
+HOMEPAGE="http://czmq.zeromq.org"
+SRC_URI="http://download.zeromq.org/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm hppa x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/libsodium:=
+ sys-apps/util-linux
+ >=net-libs/zeromq-2.1
+ <net-libs/zeromq-4
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )"
+
+DOCS=( NEWS AUTHORS )
+
+src_prepare() {
+ sed -i -e 's|-Werror||g' configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ mv "${ED}"/usr/bin/makecert{,-czmq} || die
+}
+
+pkg_postinst() {
+ elog "Due to file collisions we moved the makecert tool to makecert-${PN}."
+}