summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/enet/enet-1.3.17.ebuild')
-rw-r--r--net-libs/enet/enet-1.3.17.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/enet/enet-1.3.17.ebuild b/net-libs/enet/enet-1.3.17.ebuild
index 9c130da59dac..e3d3d51f4903 100644
--- a/net-libs/enet/enet-1.3.17.ebuild
+++ b/net-libs/enet/enet-1.3.17.ebuild
@@ -1,19 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
DESCRIPTION="Relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/ https://github.com/lsalzman/enet/"
SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
LICENSE="MIT"
SLOT="1.3/7"
-KEYWORDS="amd64 ~arm64 ppc ~ppc64 ~riscv x86"
+KEYWORDS="amd64 ~arm64 ~loong ppc ppc64 ~riscv x86"
IUSE="static-libs"
RDEPEND="!${CATEGORY}/${PN}:0"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}