summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch')
-rw-r--r--net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch b/net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch
new file mode 100644
index 000000000000..fd9f91419542
--- /dev/null
+++ b/net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch
@@ -0,0 +1,70 @@
+From 0892788776d60d92a0cddcd22078779166b736db Mon Sep 17 00:00:00 2001
+From: Dario Berzano <dario.berzano@cern.ch>
+Date: Thu, 5 Jul 2018 11:27:20 +0200
+Subject: [PATCH] Prevent shell calls longer than ARG_MAX
+
+This patch we breaks the relevant paths array into multiple shorter arrays in
+order to make the shell calls succeed.
+
+See grpc/grpc#14844.
+---
+ Makefile | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 54823a31167..25eb092d996 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2946,8 +2946,14 @@ install-headers_c:
+
+ install-headers_cxx:
+ $(E) "[INSTALL] Installing public C++ headers"
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX1), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX1), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX2), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX2), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX3), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX3), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX4), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
++ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX4), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
+
+ install-static: install-static_c install-static_cxx
+
+@@ -5278,6 +5284,8 @@ PUBLIC_HEADERS_CXX += \
+ include/grpc++/support/stub_options.h \
+ include/grpc++/support/sync_stream.h \
+ include/grpc++/support/time.h \
++
++PUBLIC_HEADERS_CXX1 += \
+ include/grpcpp/alarm.h \
+ include/grpcpp/channel.h \
+ include/grpcpp/client_context.h \
+@@ -5325,6 +5333,8 @@ PUBLIC_HEADERS_CXX += \
+ include/grpcpp/support/stub_options.h \
+ include/grpcpp/support/sync_stream.h \
+ include/grpcpp/support/time.h \
++
++PUBLIC_HEADERS_CXX2 += \
+ include/grpc/support/alloc.h \
+ include/grpc/support/atm.h \
+ include/grpc/support/atm_gcc_atomic.h \
+@@ -5376,6 +5386,8 @@ PUBLIC_HEADERS_CXX += \
+ include/grpc/impl/codegen/propagation_bits.h \
+ include/grpc/impl/codegen/slice.h \
+ include/grpc/impl/codegen/status.h \
++
++PUBLIC_HEADERS_CXX3 += \
+ include/grpc++/impl/codegen/async_stream.h \
+ include/grpc++/impl/codegen/async_unary_call.h \
+ include/grpc++/impl/codegen/byte_buffer.h \
+@@ -5406,6 +5418,8 @@ PUBLIC_HEADERS_CXX += \
+ include/grpc++/impl/codegen/stub_options.h \
+ include/grpc++/impl/codegen/sync_stream.h \
+ include/grpc++/impl/codegen/time.h \
++
++PUBLIC_HEADERS_CXX4 += \
+ include/grpcpp/impl/codegen/async_generic_service.h \
+ include/grpcpp/impl/codegen/async_stream.h \
+ include/grpcpp/impl/codegen/async_unary_call.h \