summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/http-parser/http-parser-2.7.1.ebuild')
-rw-r--r--net-libs/http-parser/http-parser-2.7.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/http-parser/http-parser-2.7.1.ebuild b/net-libs/http-parser/http-parser-2.7.1.ebuild
new file mode 100644
index 000000000000..94a06a97b5ec
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="Http request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+SRC_URI="https://github.com/nodejs/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
+IUSE="static-libs"
+
+# https://github.com/nodejs/http-parser/pull/272
+PATCHES=(
+ "${FILESDIR}"/0001-makefile-fix-DESTDIR-usage.patch
+ "${FILESDIR}"/0002-makefile-quote-variables.patch
+ "${FILESDIR}"/0003-makefile-fix-SONAME-symlink-it-should-not-be-a-full-.patch
+ "${FILESDIR}"/0004-makefile-add-CFLAGS-to-linking-command.patch
+ "${FILESDIR}"/0005-makefile-fix-install-rule-dependency.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+ use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ use static-libs && dolib.a libhttp_parser.a
+}