summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libbtbb')
-rw-r--r--net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch14
-rw-r--r--net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch b/net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch
new file mode 100644
index 000000000000..7065e000477d
--- /dev/null
+++ b/net-libs/libbtbb/files/libbtbb-2020.12.1-musl-u-char.patch
@@ -0,0 +1,14 @@
+# Fix unknown type name 'u_char' on musl
+# Closes: https://bugs.gentoo.org/829245
+# Closes: https://bugs.gentoo.org/715758
+# Upstream PR: https://github.com/greatscottgadgets/libbtbb/pull/64
+--- a/lib/src/pcap.c
++++ b/lib/src/pcap.c
+@@ -27,6 +27,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <sys/types.h>
+
+ typedef enum {
+ PCAP_OK = 0,
diff --git a/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild b/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
index c6a7e694e720..ccc78dfda1b0 100644
--- a/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
+++ b/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
@@ -23,6 +23,10 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2020.12.1-musl-u-char.patch
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_PYTHON=OFF