summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libcrafter/libcrafter-9999.ebuild')
-rw-r--r--net-libs/libcrafter/libcrafter-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-libs/libcrafter/libcrafter-9999.ebuild b/net-libs/libcrafter/libcrafter-9999.ebuild
index 1aac305c3cc0..16291e489096 100644
--- a/net-libs/libcrafter/libcrafter-9999.ebuild
+++ b/net-libs/libcrafter/libcrafter-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils git-r3 ltprune
+EAPI=7
+inherit autotools git-r3
-DESCRIPTION="a high level library for C++ designed to make easier the creation and decoding of network packets"
+DESCRIPTION="A high level C++ network packet sniffing and crafting library"
HOMEPAGE="https://github.com/pellegre/libcrafter"
EGIT_REPO_URI="https://github.com/pellegre/${PN}"
@@ -19,10 +19,13 @@ RDEPEND="
DEPEND="
${RDEPEND}
"
-
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3_p20171019-libpcap.patch
+)
S=${WORKDIR}/${P}/${PN}
src_prepare() {
+ default
eautoreconf
}
@@ -33,5 +36,7 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ dodoc "${WORKDIR}"/${P}/README
+
+ find "${ED}" -name '*.la' -delete || die
}