summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libgadu/libgadu-1.11.4.ebuild')
-rw-r--r--net-libs/libgadu/libgadu-1.11.4.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/net-libs/libgadu/libgadu-1.11.4.ebuild b/net-libs/libgadu/libgadu-1.11.4.ebuild
index 889a044752bf..7f3392a75a41 100644
--- a/net-libs/libgadu/libgadu-1.11.4.ebuild
+++ b/net-libs/libgadu/libgadu-1.11.4.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
HOMEPAGE="http://toxygen.net/libgadu/"
@@ -17,7 +15,7 @@ RESTRICT="test"
LICENSE="LGPL-2.1"
KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
-IUSE="doc ssl static-libs threads"
+IUSE="doc ssl threads"
COMMON_DEPEND="
sys-libs/zlib
@@ -26,26 +24,28 @@ COMMON_DEPEND="
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
"
-RDEPEND="${COMMON_DEPEND}
- !=net-im/kadu-0.6.0.2
- !=net-im/kadu-0.6.0.1
-"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
+RDEPEND="${COMMON_DEPEND}"
DOCS=(AUTHORS ChangeLog NEWS README)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
+ --disable-static
+ --disable-tests
--without-openssl
- $(use_with threads pthread)
$(use_with ssl gnutls)
+ $(use_with threads pthread)
)
-
- autotools-utils_src_configure
+ econf "${myeconfargs[@]}"
}
src_install() {
- use doc && HTML_DOCS=(docs/html/)
- autotools-utils_src_install
+ use doc && local HTML_DOCS=( docs/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
}