summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libiscsi/libiscsi-9999.ebuild')
-rw-r--r--net-libs/libiscsi/libiscsi-9999.ebuild51
1 files changed, 42 insertions, 9 deletions
diff --git a/net-libs/libiscsi/libiscsi-9999.ebuild b/net-libs/libiscsi/libiscsi-9999.ebuild
index 9d1977923e12..b1a76b05442c 100644
--- a/net-libs/libiscsi/libiscsi-9999.ebuild
+++ b/net-libs/libiscsi/libiscsi-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -9,29 +9,62 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ppc64 ~sparc x86"
+ if [[ ${PV} == *_p* ]] ; then
+ # The S path is too long for the test suite otherwise.
+ inherit vcs-snapshot
+
+ MY_COMMIT="22f7b26567760921fa1aad77cca642153123ea8c"
+ SRC_URI="https://github.com/sahlberg/libiscsi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~x86"
fi
DESCRIPTION="iscsi client library and utilities"
HOMEPAGE="https://github.com/sahlberg/libiscsi"
-SLOT="0"
LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="rdma test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libgcrypt:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cunit )
+"
+BDEPEND="
+ test? ( >=sys-block/tgt-1.0.58 )
+"
-RDEPEND="dev-libs/libgcrypt:0="
-DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19.0_p20230208-fix-rdma-automagic.patch
+)
src_prepare() {
default
+
+ # bug #906063
+ rm tests/test_0600_ipv6.sh || die
+
eautoreconf
}
src_configure() {
econf \
--enable-manpages \
- --disable-static \
- --disable-werror
+ $(use_with rdma) \
+ --disable-werror \
+ $(use_enable test tests)
+}
+
+src_test() {
+ emake -C tests test
}
src_install() {