summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libmbim')
-rw-r--r--net-libs/libmbim/Manifest1
-rw-r--r--net-libs/libmbim/libmbim-1.26.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/libmbim/Manifest b/net-libs/libmbim/Manifest
index 3dad220347f0..9fca404f8e11 100644
--- a/net-libs/libmbim/Manifest
+++ b/net-libs/libmbim/Manifest
@@ -1 +1,2 @@
DIST libmbim-1.24.8.tar.xz 517872 BLAKE2B ba4d44ea18ecb412d046b1c1cbd1167bd1cf0a1430486dbf760731950b088e66b25c5c870f2e1a49ea78e43bc15fdbac9efed56afa35127d33f6377325677386 SHA512 32a1ed379fb2799c8490058a16f819620290c2a08d0dacacdc7db4a31fb66a4d9c449b4b2d8fd6de898da28815a6c32e3d97a802970115ac2869e7fec0d841af
+DIST libmbim-1.26.0.tar.xz 554672 BLAKE2B b020ea81d6f06bad4c655b285423075873ea01ad253c8eb79fe6e0ce8511d6a8c684c4d8541a64dcc23b46211de117f867d5b405f08942e904156304ce746779 SHA512 b987b3271166eabda7d6767b4b3cd8f34b07ea6a43d5ed1d7cf083561b0e57affeec175a155e5bf8b998dd60f49a303cf54ad6eda146df7483cabe099c401c27
diff --git a/net-libs/libmbim/libmbim-1.26.0.ebuild b/net-libs/libmbim/libmbim-1.26.0.ebuild
new file mode 100644
index 000000000000..a4e84e6f1bbc
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.26.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libmbim/ https://gitlab.freedesktop.org/mobile-broadband/libmbim"
+SRC_URI="https://www.freedesktop.org/software/libmbim/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.56:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-Werror \
+ --disable-static \
+ --disable-gtk-doc
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}