summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnatpmp/libnatpmp-20230423-r1.ebuild')
-rw-r--r--net-libs/libnatpmp/libnatpmp-20230423-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/libnatpmp/libnatpmp-20230423-r1.ebuild b/net-libs/libnatpmp/libnatpmp-20230423-r1.ebuild
new file mode 100644
index 000000000000..303b7e4c34bc
--- /dev/null
+++ b/net-libs/libnatpmp/libnatpmp-20230423-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An alternative protocol to UPnP IGD specification"
+HOMEPAGE="
+ http://miniupnp.free.fr/libnatpmp.html
+ https://miniupnp.tuxfamily.org/libnatpmp.html
+ https://github.com/miniupnp/libnatpmp/
+"
+SRC_URI="https://miniupnp.tuxfamily.org/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ~mips ppc ppc64 ~riscv sparc x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-20150609-gentoo.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ # Override HEADERS for missing declspec.h wrt #506832
+ emake HEADERS="natpmp.h natpmp_declspec.h" PREFIX="${ED}" GENTOO_LIBDIR="$(get_libdir)" install
+
+ dodoc Changelog.txt README
+ doman natpmpc.1
+}