summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libpcap/libpcap-9999.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild36
1 files changed, 16 insertions, 20 deletions
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index 531bf51fe6d5..770877d74270 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools multilib-minimal
@@ -12,18 +12,19 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
inherit git-r3
else
- VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/tcpdump.asc
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/tcpdump.asc
inherit verify-sig
SRC_URI="https://www.tcpdump.org/release/${P}.tar.gz"
SRC_URI+=" verify-sig? ( https://www.tcpdump.org/release/${P}.tar.gz.sig )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink rdma remote static-libs usb yydebug"
+IUSE="bluetooth dbus netlink rdma remote static-libs test usb yydebug"
+RESTRICT="!test? ( test )"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -35,8 +36,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
+ app-alternatives/yacc
sys-devel/flex
- virtual/yacc
dbus? ( virtual/pkgconfig )
"
@@ -44,12 +45,6 @@ if [[ ${PV} != *9999* ]] ; then
BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-tcpdump )"
fi
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
- "${FILESDIR}"/${PN}-1.10.0-usbmon.patch
- "${FILESDIR}"/${PN}-9999-prefix-darwin.patch
-)
-
src_prepare() {
default
@@ -61,8 +56,10 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
+ # bug #884275
+ export LEX=flex
+
+ ECONF_SOURCE="${S}" econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
$(use_enable rdma) \
@@ -75,6 +72,11 @@ multilib_src_configure() {
multilib_src_compile() {
emake all shared
+ use test && emake testprogs
+}
+
+multilib_src_test() {
+ testprogs/findalldevstest || die
}
multilib_src_install_all() {
@@ -86,10 +88,4 @@ multilib_src_install_all() {
fi
find "${ED}" -name '*.la' -delete || die
-
- # We need this to build pppd on G/FBSD systems
- if [[ "${USERLAND}" == "BSD" ]]; then
- insinto /usr/include
- doins pcap-int.h portability.h
- fi
}