summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 1db805f951f8..8e1c6617634e 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1,2 +1,3 @@
DIST libquotient-0.6.11.tar.gz 562144 BLAKE2B 75be68371ac1873e38f9ff81273419ed1eb773d02408137a7dafc9a60f520a2ba0b5556783272f8902dd98f7f5dac3a92ab393da5dd48acfffeba8b1631a84dd SHA512 76a11c80822ae3279d643559b481a09fe45b1f8effb7b0efeeb7ab54f13dd06997d9220dcb36c13d270f5641f496dba350f528c49e239757f4546de9fbe940fa
DIST libquotient-0.7.0.tar.gz 667312 BLAKE2B 020baf8bcbbcedd6220e4f3476b152b3a0e88d53786e5b4575f9c096aa36847220a186ca782e068b2fd1f54771e45e1b313d10913af2cc2be3a1c45074acb733 SHA512 6770e3caa6198a77fc33bf7edd2a34d5673e01474b639aa020af989046ff04c44ff5ce26b6418ae31fcca49cc54a147052153ed5c60706f26c177ebd57d452c5
+DIST libquotient-0.7.1.tar.gz 667590 BLAKE2B 93c601960c43511ba0118ac0224c34064a6c1b1fa9a526ca8a064495e8d5b981ab197ed958ced3ba4bf869e0554ee37d2be82cddb6610e9d5ef371a1d3a144a7 SHA512 88819cafb49712d53c692008be69ea1fc01ca1ac6aedc15696eba2f830956660d185fb07273d50c7dc3e9208314ac24838746d5d9e70b3aad7fccbd15fd7c545
diff --git a/net-libs/libquotient/libquotient-0.7.1.ebuild b/net-libs/libquotient/libquotient-0.7.1.ebuild
new file mode 100644
index 000000000000..4a30091b1f75
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ )
+ cmake_src_configure
+}