summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsignon-glib')
-rw-r--r--net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch28
-rw-r--r--net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch31
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-2.1-r2.ebuild (renamed from net-libs/libsignon-glib/libsignon-glib-2.1.ebuild)39
-rw-r--r--net-libs/libsignon-glib/metadata.xml2
4 files changed, 85 insertions, 15 deletions
diff --git a/net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch b/net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch
new file mode 100644
index 000000000000..b31bd46a825e
--- /dev/null
+++ b/net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch
@@ -0,0 +1,28 @@
+From fc1098b3a376a04020c9e733eafda9fa0ac51723 Mon Sep 17 00:00:00 2001
+From: Pino Toscano <toscano.pino@tiscali.it>
+Date: Sat, 2 Jan 2021 14:19:18 +0100
+Subject: [PATCH] build: make documentation really optional
+
+Build of the documentation only if the meson option for it is enabled.
+---
+ meson.build | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 5d0de55..b10f80d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -23,7 +23,9 @@ endif
+ root_dir = include_directories ('.')
+
+ subdir('libsignon-glib')
+-subdir('docs')
++if get_option('documentation')
++ subdir('docs')
++endif
+
+ if get_option('python')
+ subdir('pygobject')
+--
+GitLab
+
diff --git a/net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch b/net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch
new file mode 100644
index 000000000000..66254e398029
--- /dev/null
+++ b/net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch
@@ -0,0 +1,31 @@
+From 4fae9155a19aca601072f361768e0bf8ed556b1e Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Tue, 11 Jan 2022 22:05:11 +0100
+Subject: [PATCH] Fix build with meson >= 0.61.0
+
+Otherwise it fails with "docs/reference/meson.build:21:6: ERROR:
+gnome.gtkdoc keyword argument 'expand_content_files' was of type
+array[File] but should have been array[str]".
+---
+ docs/reference/meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/docs/reference/meson.build b/docs/reference/meson.build
+index 654404b..3927109 100644
+--- a/docs/reference/meson.build
++++ b/docs/reference/meson.build
+@@ -47,9 +47,9 @@ gnome.gtkdoc(
+ 'libsignon-glib.types',
+ ],
+ content_files: doc_content_files,
+- expand_content_files: files(
++ expand_content_files: [
+ 'migrating-1to2.xml'
+- ),
++ ],
+ fixxref_args: [
+ '--extra-dir=@0@'.format(join_paths(glib_docpath, 'glib')),
+ '--extra-dir=@0@'.format(join_paths(glib_docpath, 'gobject')),
+--
+GitLab
+
diff --git a/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild b/net-libs/libsignon-glib/libsignon-glib-2.1-r2.ebuild
index a07adeedb261..84711961b404 100644
--- a/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
+++ b/net-libs/libsignon-glib/libsignon-glib-2.1-r2.ebuild
@@ -1,21 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7} )
-inherit meson python-r1 vala vcs-snapshot
+PYTHON_COMPAT=( python3_{9..12} )
+inherit meson python-r1 vala
DESCRIPTION="GLib binding for the D-Bus API provided by signond"
-HOMEPAGE="https://01.org/gsso/"
+HOMEPAGE="https://accounts-sso.gitlab.io/"
SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-VERSION_${PV}"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 arm64 x86"
+KEYWORDS="amd64 arm64 ~riscv x86"
IUSE="debug doc +introspection python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} introspection )"
+# needs more love
+RESTRICT="test"
RDEPEND="
dev-libs/glib:2
@@ -27,22 +30,28 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
-BDEPEND="
+BDEPEND="$(python_gen_any_dep)
+ $(vala_depend)
dev-util/gdbus-codegen
dev-util/glib-utils
doc? ( dev-util/gtk-doc )
test? ( dev-libs/check )
"
-# needs more love
-RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/${P}-docs-optional.patch"
+ "${FILESDIR}/${P}-meson-0.61.patch"
+)
-src_prepare() {
- default
+python_check_deps() { return 0; }
- vala_src_prepare
+pkg_setup() {
+ python_setup
+}
- use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+src_prepare() {
+ default
+ vala_setup
cp libsignon-glib/*.xml libsignon-glib/interfaces || die
}
@@ -51,6 +60,7 @@ src_configure() {
myconfigure() {
local emesonargs=(
-Ddebugging=$(usex debug true false)
+ -Ddocumentation=$(usex doc true false)
-Dintrospection=$(usex introspection true false)
-Dpython=$(usex python true false)
-Dtests=$(usex test true false)
@@ -74,7 +84,7 @@ src_compile() {
fi
}
-src_compile() {
+src_test() {
if use python; then
python_foreach_impl run_in_build_dir meson_src_test
else
@@ -87,6 +97,7 @@ src_install() {
if use python; then
python_foreach_impl run_in_build_dir meson_src_install
+ python_foreach_impl python_optimize
else
meson_src_install
fi
diff --git a/net-libs/libsignon-glib/metadata.xml b/net-libs/libsignon-glib/metadata.xml
index 2fdbf33d963d..8641e5bdd399 100644
--- a/net-libs/libsignon-glib/metadata.xml
+++ b/net-libs/libsignon-glib/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>kde@gentoo.org</email>