summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libyang/files/libyang-2.0.0-cmake.patch')
-rw-r--r--net-libs/libyang/files/libyang-2.0.0-cmake.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/net-libs/libyang/files/libyang-2.0.0-cmake.patch b/net-libs/libyang/files/libyang-2.0.0-cmake.patch
new file mode 100644
index 000000000000..09b83b3639fa
--- /dev/null
+++ b/net-libs/libyang/files/libyang-2.0.0-cmake.patch
@@ -0,0 +1,12 @@
+# https://github.com/CESNET/libyang/pull/1581
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,8 +35,6 @@ elseif ("${BUILD_TYPE_UPPER}" STREQUAL "ABICHECK")
+ set(CMAKE_BUILD_TYPE "ABICheck" CACHE STRING "Build Type" FORCE)
+ elseif ("${BUILD_TYPE_UPPER}" STREQUAL "DOCONLY")
+ set(CMAKE_BUILD_TYPE "DocOnly" CACHE STRING "Build Type" FORCE)
+-else ()
+- message(FATAL_ERROR "Unknown CMAKE_BUILD_TYPE \"${CMAKE_BUILD_TYPE}\".")
+ endif ()
+
+ # check the supported platform