summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/neon/neon-0.30.2.ebuild')
-rw-r--r--net-libs/neon/neon-0.30.2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-libs/neon/neon-0.30.2.ebuild b/net-libs/neon/neon-0.30.2.ebuild
index 506f311c68b3..eea871bc8d5e 100644
--- a/net-libs/neon/neon-0.30.2.ebuild
+++ b/net-libs/neon/neon-0.30.2.ebuild
@@ -45,10 +45,12 @@ src_prepare() {
# Fix compatibility with OpenSSL >=1.1.
sed -e "s/RSA_F_RSA_PRIVATE_ENCRYPT/RSA_F_RSA_OSSL_PRIVATE_ENCRYPT/" -i src/ne_pkcs11.c || die "sed failed"
- # Support LibreSSL.
- # Functions RSA_meth_get0_app_data() and RSA_meth_set0_app_data() are not implemented in LibreSSL 2.9.1.
- sed -e "1202s/#if OPENSSL_VERSION_NUMBER < 0x10100000L/& || defined(LIBRESSL_VERSION_NUMBER)/" -i src/ne_openssl.c || die "sed failed"
- sed -e "97a #if defined(LIBRESSL_VERSION_NUMBER)\nstatic void *RSA_meth_get0_app_data(const RSA_METHOD *meth)\n{\n return meth->app_data;\n}\nstatic int RSA_meth_set0_app_data(RSA_METHOD *meth, void *app_data)\n{\n meth->app_data = app_data;\n return 1;\n}\n#endif" -i src/ne_pkcs11.c || die "sed failed"
+ if has_version "<dev-libs/libressl-3.0.0"; then
+ # Support LibreSSL.
+ # Functions RSA_meth_get0_app_data() and RSA_meth_set0_app_data() are not implemented in LibreSSL 2.9.2.
+ sed -e "1202s/#if OPENSSL_VERSION_NUMBER < 0x10100000L/& || defined(LIBRESSL_VERSION_NUMBER)/" -i src/ne_openssl.c || die "sed failed"
+ sed -e "97a #if defined(LIBRESSL_VERSION_NUMBER)\nstatic void *RSA_meth_get0_app_data(const RSA_METHOD *meth)\n{\n return meth->app_data;\n}\nstatic int RSA_meth_set0_app_data(RSA_METHOD *meth, void *app_data)\n{\n meth->app_data = app_data;\n return 1;\n}\n#endif" -i src/ne_pkcs11.c || die "sed failed"
+ fi
eapply_user