summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ntirpc/ntirpc-3.0.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-3.0.ebuild b/net-libs/ntirpc/ntirpc-3.0.ebuild
new file mode 100644
index 000000000000..f492c2991f56
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ app-crypt/mit-krb5
+ dev-libs/userspace-rcu
+ net-libs/libnsl
+ rdma? ( sys-fabric/librdmacm )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}