summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/toxext/toxext-0.0.2.ebuild')
-rw-r--r--net-libs/toxext/toxext-0.0.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/toxext/toxext-0.0.2.ebuild b/net-libs/toxext/toxext-0.0.2.ebuild
new file mode 100644
index 000000000000..356610149149
--- /dev/null
+++ b/net-libs/toxext/toxext-0.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Extension Library for Tox"
+HOMEPAGE="https://github.com/toxext/toxext"
+SRC_URI="https://github.com/toxext/toxext/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="net-libs/tox:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i 's/-Werror//' CMakeLists.txt || die
+}