summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/toxext/toxext-0.0.3.ebuild')
-rw-r--r--net-libs/toxext/toxext-0.0.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-libs/toxext/toxext-0.0.3.ebuild b/net-libs/toxext/toxext-0.0.3.ebuild
index 83c395524343..4e41feba68bf 100644
--- a/net-libs/toxext/toxext-0.0.3.ebuild
+++ b/net-libs/toxext/toxext-0.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Extension Library for Tox"
HOMEPAGE="https://github.com/toxext/toxext"
@@ -22,4 +22,8 @@ src_prepare() {
sed -i 's/-Werror//' CMakeLists.txt || die
sed -i '/-fsanitize=/d' test/CMakeLists.txt || die
+
+ # Fix build with CLANG and LLD.
+ # https://bugs.gentoo.org/831338
+ append-flags -fPIC
}