summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/uhttpmock')
-rw-r--r--net-libs/uhttpmock/Manifest2
-rw-r--r--net-libs/uhttpmock/metadata.xml5
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.4.0.ebuild44
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.5.0.ebuild44
4 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/uhttpmock/Manifest b/net-libs/uhttpmock/Manifest
new file mode 100644
index 000000000000..56218729a9ae
--- /dev/null
+++ b/net-libs/uhttpmock/Manifest
@@ -0,0 +1,2 @@
+DIST uhttpmock-0.4.0.tar.xz 295392 SHA256 0d9a75ac66070879a14caabddfaa7bd4e888e2abb03f9ac73610921ed341b571 SHA512 0f98db886aa02a911fc94c957a371651f9be5784602ea0492d04798dcf12c4a519a292ede9d37b25a965832e5d96ca9da7ce0ca8127af74d3986c4ef74e1f527 WHIRLPOOL 2d5a00407ed9c5022cb86773ee87580b6e8573c451beee9eeec535cbfb0b8e8d7847d6ec7f35914b9d4f3a3744d608383db181779dbc2ca2cb86667545b5f4f4
+DIST uhttpmock-0.5.0.tar.xz 296908 SHA256 26da182a2db2579c5ba4dad9096d52099e0766228c295cfbaed6de4046f7d16e SHA512 952b618f3a12d7190f3812bc0bd53dd655a83d27f29bb749e62b36a08492bf535b85db7f5ff66f15c72bf5574696149f00476041f225ca6039ad87b221f5a1c6 WHIRLPOOL 8b85b70b18f47195726298dea99e8b3546d1a62bb15fc84839a152dfe050e5f599246a31394f9c542b8d3c5ff10ac9f403a9c467f95f2a2e2e112ad72abb250b
diff --git a/net-libs/uhttpmock/metadata.xml b/net-libs/uhttpmock/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/uhttpmock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/net-libs/uhttpmock/uhttpmock-0.4.0.ebuild b/net-libs/uhttpmock/uhttpmock-0.4.0.ebuild
new file mode 100644
index 000000000000..105b2a47ddc3
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.com/uhttpmock/uhttpmock"
+SRC_URI="http://tecnocode.co.uk/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
+ >=net-libs/libsoup-2.37.91:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
diff --git a/net-libs/uhttpmock/uhttpmock-0.5.0.ebuild b/net-libs/uhttpmock/uhttpmock-0.5.0.ebuild
new file mode 100644
index 000000000000..ce0470b82849
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.com/uhttpmock/uhttpmock"
+SRC_URI="http://tecnocode.co.uk/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
+ >=net-libs/libsoup-2.37.91:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}