summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/xrootd-ceph')
-rw-r--r--net-libs/xrootd-ceph/Manifest1
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-5.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/Manifest b/net-libs/xrootd-ceph/Manifest
index dad746f70d08..6c0aa9eeb5fc 100644
--- a/net-libs/xrootd-ceph/Manifest
+++ b/net-libs/xrootd-ceph/Manifest
@@ -2,3 +2,4 @@ DIST xrootd-ceph-4.12.4.tar.gz 81253 BLAKE2B 0b3d0e347e02b6948550c44487e0edb1c65
DIST xrootd-ceph-4.12.5.tar.gz 81838 BLAKE2B a61a814741abd04723755122606eef4544769d5cbe3828977617384a8eaddcfae4591f1ac2515020f300feff5cb11b7af362c15719313085e0f76b5157ab862c SHA512 db0fe7f8713ddf91ce200b364d460206ecf2a08153fb561a99e0780db84ad9d716f9f9fbc3994258e9269fce08d16326c4473bdae200c644cbf4d3bd1144a6eb
DIST xrootd-ceph-5.0.2.tar.gz 81255 BLAKE2B 529d2c361cc7660cdbb481cdbae1fbf4cd706f29df868c645775b96efa7efaaecd9ea8b7d915c15b5ff78ad1395bb8271a3f1c1105ea0b42dced77efa33acaa7 SHA512 9f8de694a9a864ee0a963bb47c603d2cd3a77b4e13efacdd7f35674016358ce3b0a3fc5850098a29774749f54fa82db12c0e56b55d814873c124d9e19c7c23c5
DIST xrootd-ceph-5.0.3.tar.gz 81835 BLAKE2B 1be45c78dd0ec4b20451cfa4a8a579e076e718509a47fa04027207c12e433338decefb9f82749cc15cae3cad75d97485fe0a7d6582cdcc0739bd222bc1d97b6b SHA512 3338a0ab0446e4c7ee3d232f5cce8f93c49e040b4792aa52f9dcf6f27f6767e6ffbaff17eb30a87c5b3ff713e1b0c4edb24d8d116c91351c4ed0c13963f80fc9
+DIST xrootd-ceph-5.1.0.tar.gz 81939 BLAKE2B 607fe5d31369c88402d7ed993fde3f058f873defe97900f2b7909a3630f6927efeb98c08acd31be68ec7d6b997464f6d3cea5da5d08a3e84570ff670861a50f8 SHA512 cc05a00684bde5ee9adfe61f261393a177d21569f4570d41fbaf65d1276dbc18829d1b532ec10df93a1a60d25fb2de54078b4bf1cb30ab383d4af92178147ee1
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-5.1.0.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-5.1.0.ebuild
new file mode 100644
index 000000000000..bdacb70cc802
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-5.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=net-libs/xrootd-5.0.0
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-util/cppunit )"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrdCeph.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdCephTests\.so"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ # As of 5.0.3 the default plug-in version is still 4.
+ -DPLUGIN_VERSION=$(ver_cut 1)
+ )
+ cmake_src_configure
+}