summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/zeromq')
-rw-r--r--net-libs/zeromq/files/zeromq-4.3.4-gcc-13.patch55
-rw-r--r--net-libs/zeromq/zeromq-4.3.4-r2.ebuild71
2 files changed, 126 insertions, 0 deletions
diff --git a/net-libs/zeromq/files/zeromq-4.3.4-gcc-13.patch b/net-libs/zeromq/files/zeromq-4.3.4-gcc-13.patch
new file mode 100644
index 000000000000..79deeacc2bd8
--- /dev/null
+++ b/net-libs/zeromq/files/zeromq-4.3.4-gcc-13.patch
@@ -0,0 +1,55 @@
+https://github.com/zeromq/libzmq/commit/438d5d88392baffa6c2c5e0737d9de19d6686f0d
+
+From 438d5d88392baffa6c2c5e0737d9de19d6686f0d Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Tue, 20 Dec 2022 21:45:16 +0000
+Subject: [PATCH] src/secure_allocator.hpp: define missing 'rebind' type
+
+`gcc-13` added an assert to standard headers to make sure custom
+allocators have intended implementation of rebind type instead
+of inherited rebind. gcc change:
+ https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=64c986b49558a7
+
+Without the fix build fails on this week's `gcc-13` as:
+
+ [ 92%] Building CXX object tests/CMakeFiles/test_security_curve.dir/test_security_curve.cpp.o
+ In file included from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:34,
+ from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_uninitialized.h:64,
+ from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/memory:69,
+ from tests/../src/secure_allocator.hpp:42,
+ from tests/../src/curve_client_tools.hpp:49,
+ from tests/test_security_curve.cpp:53:
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h: In instantiation of 'struct std::__allocator_traits_base::__rebind<zmq::secure_allocator_t<unsigned char>, unsigned char, void>':
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:94:11: required by substitution of 'template<class _Alloc, class _Up> using std::__alloc_rebind = typename std::__allocator_traits_base::__rebind<_Alloc, _Up>::type [with _Alloc = zmq::secure_allocator_t<unsigned char>; _Up = unsigned char]'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:228:8: required by substitution of 'template<class _Alloc> template<class _Tp> using std::allocator_traits< <template-parameter-1-1> >::rebind_alloc = std::__alloc_rebind<_Alloc, _Tp> [with _Tp = unsigned char; _Alloc = zmq::secure_allocator_t<unsigned char>]'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:126:65: required from 'struct __gnu_cxx::__alloc_traits<zmq::secure_allocator_t<unsigned char>, unsigned char>::rebind<unsigned char>'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:88:21: required from 'struct std::_Vector_base<unsigned char, zmq::secure_allocator_t<unsigned char> >'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:423:11: required from 'class std::vector<unsigned char, zmq::secure_allocator_t<unsigned char> >'
+ tests/../src/curve_client_tools.hpp:64:76: required from here
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:70:31: error: static assertion failed: allocator_traits<A>::rebind_alloc<A::value_type> must be A
+ 70 | _Tp>::value,
+ | ^~~~~
+
+The change adds trivial `rebind` definition with expected return type
+and satisfies conversion requirements.
+--- a/src/secure_allocator.hpp
++++ b/src/secure_allocator.hpp
+@@ -99,6 +99,17 @@ bool operator!= (const secure_allocator_t<T> &, const secure_allocator_t<U> &)
+ #else
+ template <typename T> struct secure_allocator_t : std::allocator<T>
+ {
++ secure_allocator_t () ZMQ_DEFAULT;
++
++ template <class U>
++ secure_allocator_t (const secure_allocator_t<U> &) ZMQ_NOEXCEPT
++ {
++ }
++
++ template <class U> struct rebind
++ {
++ typedef secure_allocator_t<U> other;
++ };
+ };
+ #endif
+ }
+
diff --git a/net-libs/zeromq/zeromq-4.3.4-r2.ebuild b/net-libs/zeromq/zeromq-4.3.4-r2.ebuild
new file mode 100644
index 000000000000..06892942f602
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.3.4-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="https://zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc drafts +libbsd pgm +sodium static-libs test unwind"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ libbsd? ( dev-libs/libbsd:= )
+ sodium? ( dev-libs/libsodium:= )
+"
+DEPEND="
+ ${RDEPEND}
+ !elibc_Darwin? ( sys-apps/util-linux )
+"
+BDEPEND="
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ pgm? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-13.patch
+)
+
+src_prepare() {
+ sed \
+ -e '/libzmq_werror=/s:yes:no:g' \
+ -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --without-pgm
+ $(use_enable drafts)
+ $(use_enable libbsd)
+ $(use_enable static-libs static)
+ $(use_enable unwind libunwind)
+ $(use_with sodium libsodium)
+ $(use_with doc docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}