summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.58.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index e31d99999ebc..7534ef907a74 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -3,3 +3,4 @@ DIST nghttp2-1.51.0-pthread.patch 24623 BLAKE2B 55c63b4851788e4e18df1f7881fc370b
DIST nghttp2-1.51.0.tar.xz 4115988 BLAKE2B ca3c5fb439b60f67ce5447c957397c16c7659432d3a3b25076b88142318675eb2af9f039a86ce88df8af3bd0167d98f14cdeb8dad2d01eda1378015acefa354e SHA512 0212680e57a15f9afca3b5226429edebd2fe8a52117480007d4472cd0c1bd3aa4d9f21269c637a11efd0f2146a3ee16c3c07ab35d9fb3d4566235d3a14268eeb
DIST nghttp2-1.52.0.tar.xz 1491732 BLAKE2B a77ff3e1f901768daf7e681cad06bf3b9ea44876dba76e06c2aaec8637196f27ee7213e3ef52da53b995f68a2a617f64947b4392f57140310bdc5a1d994ad1b2 SHA512 3af1ce13270f7afc8652bd3de71200d9632204617fe04d2be7156d60eeb1a5cc415573677791a399ae03577e8e3256939b1b05d27dbd98dee504d09ec5325d56
DIST nghttp2-1.57.0.tar.xz 1543568 BLAKE2B 6fad0f922477f896db14319433569b99cf599217335b5af189cc7b460f78996a801845927040d4f529151bbcc572b2cf4d8d28eae2647fad1fd35f796fd4afb8 SHA512 d914eb48afd1ea182c1b2a454bf5e7963a7e28165f1d6d29bb83dd61a1b611c8c469e72a7a22daf23b8037f6e5ae9d4e791150b7d135746c1a5ec71ceb777f92
+DIST nghttp2-1.58.0.tar.xz 1546332 BLAKE2B db51bf6a0307f1465f4fcda7555b3a720800ee09aa8d26533fb6726f9b56a137435f5ea745f8fa5f927c8638e2a8fd371b04825e23c6a802070cebcfb654d256 SHA512 97b70727c633be1168df6a5b48617dde113b1d1e34176ec8bf22f4449041af2f73b2ada438d14336c9712271ec6bfc7525f000c8ca6a7a9f8d06db01b876dd1c
diff --git a/net-libs/nghttp2/nghttp2-1.58.0.ebuild b/net-libs/nghttp2/nghttp2-1.58.0.ebuild
new file mode 100644
index 000000000000..c028ca91bbb4
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.58.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/1.14" # 1.<SONAME>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug hpack-tools jemalloc static-libs systemd test utils xml"
+
+RESTRICT="!test? ( test )"
+
+SSL_DEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist(-),${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ hpack-tools? ( >=dev-libs/jansson-2.5:= )
+ jemalloc? ( dev-libs/jemalloc:=[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ systemd? ( >=sys-apps/systemd-209 )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_FAILMALLOC=OFF
+ -DENABLE_WERROR=OFF
+ -DENABLE_THREADS=ON
+ -DENABLE_DEBUG=$(usex debug)
+ -DENABLE_HPACK_TOOLS=$(multilib_native_usex hpack-tools)
+ $(cmake_use_find_package hpack-tools Jansson)
+ -DWITH_JEMALLOC=$(multilib_native_usex jemalloc)
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ $(cmake_use_find_package systemd Systemd)
+ $(cmake_use_find_package test CUnit)
+ -DENABLE_APP=$(multilib_native_usex utils)
+ -DWITH_LIBXML2=$(multilib_native_usex xml)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ eninja check
+}