summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/davix/davix-0.8.5.ebuild4
-rw-r--r--net-libs/davix/files/davix-0.8.5-gcc14.patch12
2 files changed, 16 insertions, 0 deletions
diff --git a/net-libs/davix/davix-0.8.5.ebuild b/net-libs/davix/davix-0.8.5.ebuild
index 3db5aa1aa72f..61e8ecd0f6ec 100644
--- a/net-libs/davix/davix-0.8.5.ebuild
+++ b/net-libs/davix/davix-0.8.5.ebuild
@@ -39,6 +39,10 @@ RDEPEND="${CDEPEND}"
REQUIRED_USE="test? ( tools )"
+PATCHES=(
+ "${FILESDIR}/${P}-gcc14.patch"
+)
+
src_prepare() {
cmake_src_prepare
diff --git a/net-libs/davix/files/davix-0.8.5-gcc14.patch b/net-libs/davix/files/davix-0.8.5-gcc14.patch
new file mode 100644
index 000000000000..2e2c8bd663ac
--- /dev/null
+++ b/net-libs/davix/files/davix-0.8.5-gcc14.patch
@@ -0,0 +1,12 @@
+Fix bundled rapidjson build with GCC 14.
+
+--- a/src/libs/rapidjson/document.h
++++ b/src/libs/rapidjson/document.h
+@@ -316,8 +316,6 @@ struct GenericStringRef {
+
+ GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
+
+- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
+-
+ //! implicit conversion to plain CharType pointer
+ operator const Ch *() const { return s; }