summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/b4')
-rw-r--r--net-mail/b4/Manifest3
-rw-r--r--net-mail/b4/b4-0.12.1.ebuild27
-rw-r--r--net-mail/b4/b4-0.13.0.ebuild27
-rw-r--r--net-mail/b4/b4-0.4.0.ebuild20
-rw-r--r--net-mail/b4/metadata.xml14
5 files changed, 65 insertions, 26 deletions
diff --git a/net-mail/b4/Manifest b/net-mail/b4/Manifest
index 5c1e554109a3..590a6ca033d5 100644
--- a/net-mail/b4/Manifest
+++ b/net-mail/b4/Manifest
@@ -1 +1,2 @@
-DIST b4-0.4.0.tar.gz 47904 BLAKE2B 4e5b59fab3b05b2641691e81d12a48cdf68fd9344e39df68c10c8613084807dda49f8ca08e7f60bd6bfb833054a350b9f4ee7047e45a8fe7354413d73be04a54 SHA512 7d78b8b67d9da9cec60e2e45a53520fb00746d78d5b5fb480e025b3fd98ddfa42e54c34eaafa20e88d80525a820fb5919d3ec4215846d47ec5d4558d906d6c4c
+DIST b4-0.12.1.tar.gz 233691 BLAKE2B d10dc969d16722083ab0b79b7a2a26df44dbe2d5a8a804a0339903ff30f2a25a915e7755d4c5a9855d9b3abd8fbd6a3ff3b8034a6679491835446fdd24ee1b0f SHA512 6a7cacfdda6b4c8c3b87554c1b8fc7b2e797ea0b44476943aa6b75a901dc57cc17fab2a584d63c3724967ee8e6d9b3070dea94a6e4df43547a521ba741366032
+DIST b4-0.13.0.tar.gz 243729 BLAKE2B b004209ab289026e5013003355873feeef0c275dbd638a9ca725adc0bb594ea5091094b2fb30737fad9ef60a742809699c9c9a0e0015e9ebf58ee3d1c90fc989 SHA512 692d01970019d3fc604187882004d97f4286a22d87e5778d7830ec247757534a9d951fa8edfe9e04e8f14107c77b08b6c15024f37bd99f4abf3aa0d823df21e5
diff --git a/net-mail/b4/b4-0.12.1.ebuild b/net-mail/b4/b4-0.12.1.ebuild
new file mode 100644
index 000000000000..db383dc61a8b
--- /dev/null
+++ b/net-mail/b4/b4-0.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Utility for fetching patchsets from public-inbox"
+HOMEPAGE="https://pypi.org/project/b4/"
+# pypi lacks tests
+SRC_URI="https://git.kernel.org/pub/scm/utils/b4/b4.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/dkimpy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.1[${PYTHON_USEDEP}]
+ >=dev-python/patatt-0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-vcs/git-filter-repo-2.30[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/net-mail/b4/b4-0.13.0.ebuild b/net-mail/b4/b4-0.13.0.ebuild
new file mode 100644
index 000000000000..21f935f044e6
--- /dev/null
+++ b/net-mail/b4/b4-0.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Utility for fetching patchsets from public-inbox"
+HOMEPAGE="https://pypi.org/project/b4/"
+# pypi lacks tests
+SRC_URI="https://git.kernel.org/pub/scm/utils/b4/b4.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/dkimpy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.1[${PYTHON_USEDEP}]
+ >=dev-python/patatt-0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-vcs/git-filter-repo-2.30[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/net-mail/b4/b4-0.4.0.ebuild b/net-mail/b4/b4-0.4.0.ebuild
deleted file mode 100644
index 211469b6276f..000000000000
--- a/net-mail/b4/b4-0.4.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility for fetching patchsets from public-inbox"
-HOMEPAGE="https://pypi.org/project/b4/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
diff --git a/net-mail/b4/metadata.xml b/net-mail/b4/metadata.xml
index 474123637388..2682456e0d77 100644
--- a/net-mail/b4/metadata.xml
+++ b/net-mail/b4/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
-<email>zx2c4@gentoo.org</email>
-<name>Jason A. Donenfeld</name>
-</maintainer>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">b4</remote-id>
+ </upstream>
</pkgmetadata>