summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/email/email-3.0.5.ebuild')
-rw-r--r--net-mail/email/email-3.0.5.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-mail/email/email-3.0.5.ebuild b/net-mail/email/email-3.0.5.ebuild
deleted file mode 100644
index 5f321515d327..000000000000
--- a/net-mail/email/email-3.0.5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit flag-o-matic
-
-DESCRIPTION="Advanced CLI tool for sending email"
-HOMEPAGE="http://www.cleancode.org/projects/email"
-SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- append-ldflags $(no-as-needed)
-}
-
-src_compile() {
- local myconf=""
-
- if [ -f /etc/conf.d/clock ]; then
- . /etc/conf.d/clock
- if [ x$CLOCK = "xUTC" ]; then
- elog "Using UTC timestamps (from /etc/conf.d/clock)"
- myconf="${myconf} --with-utc"
- fi
- fi
-
- sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
- sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- doman email.1
- dodoc INSTALL quoted-printable.rfc RFC821 TODO
- make DESTDIR="${D}" install || die "install failed"
-}
-
-pkg_preinst() {
- rm "${D}"/usr/share/doc/"${P}"/email.1
-}
-
-pkg_postinst() {
- echo
- elog "Do not forget to edit /etc/email/email.conf file before using email."
- echo
-}