summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/getmail/getmail-6.9.ebuild')
-rw-r--r--net-mail/getmail/getmail-6.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-6.9.ebuild b/net-mail/getmail/getmail-6.9.ebuild
new file mode 100644
index 000000000000..7721b8688ee0
--- /dev/null
+++ b/net-mail/getmail/getmail-6.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="ssl"
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://www.getmail6.org/"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+S="${WORKDIR}/getmail6-${PV}"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}